Bug 30513 - iostatistics not working with offboard PCI IDE controller (promise)
Summary: iostatistics not working with offboard PCI IDE controller (promise)
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Arjan van de Ven
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-04 07:11 UTC by Ed McKenzie
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 10:19:47 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ed McKenzie 2001-03-04 07:11:36 UTC
iostat 1 displays zeroes for all disk block statistics except on the first
iteration.

hardware: IDE disks on a promise ata66 controller, scsi disk on an initio
9100uw controller, same issue with all disks

Comment 1 Preston Brown 2001-03-05 21:28:04 UTC
are you sure you are doing IO while running iostat?  Works fine for me here. 

start iostat 1 in one window and then run say "find / -name foo" in another.  I
think you will see it works fine.

Comment 2 Ed McKenzie 2001-03-05 21:48:35 UTC
Nope, it's still not displaying. Running find on both IDE drives shows up zero 
in all counters except the CPU usage, which is about where it usually is for 
this kind of activity.

Incidentally, I've also noticed that procinfo no longer shows disk block stats 
in the right column, as it did in RH7.

'iostat 1' log attached. A single instance of find / was running for the entire 
run.

[eem12@eem12 eem12]$ iostat 1
Linux 2.4.1-0.1.14 (eem12.resnet.cornell.edu)   03/05/2001

avg-cpu:  %user   %nice    %sys   %idle
          29.36   13.92    4.09   52.63
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00         18          0
dev11-0        0.00         0.00         0.00         32          0

avg-cpu:  %user   %nice    %sys   %idle
          34.00    0.00    0.00   66.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          33.00    0.00    0.00   67.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          29.00    0.00    7.00   64.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          33.00    0.00    1.00   66.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          33.00    0.00    1.00   66.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          35.00    0.00    1.00   64.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          31.00    0.00    5.00   64.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          34.00    0.00    1.00   65.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0     0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          32.00    0.00    5.00   63.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0

avg-cpu:  %user   %nice    %sys   %idle
          27.00    1.00    2.00   70.00
Device:        tps   Blk_read/s   Blk_wrtn/s   Blk_read   Blk_wrtn
dev3-0        0.00         0.00         0.00          0          0
dev11-0        0.00         0.00         0.00          0          0


[eem12@eem12 eem12]$


Comment 3 Ed McKenzie 2001-03-05 21:53:40 UTC
btw, this was on a freshly booted box, so the fs cache wasn't primed.


Comment 4 Ed McKenzie 2001-03-06 00:42:18 UTC
Looking at the device numbers, it seems iostat is ignoring the PCI IDE board.

dev11-0 is the scsi CD writer, and dev3-0 is the IDE CD-ROM.  Both of those show
up properly if IO occurs on the respective devices. Of course, iostat would be
even more useful if it showed statistics for my hard disks. :)

Are off-board IDE boards not going to be fully supported by system tools in
RH7.1? I would hope they would, since several popular on-board chipsets are
buggy and can be dangerous to use in many cases.

Comment 5 Preston Brown 2001-03-09 05:10:28 UTC
iostat is manifesting the problem, but the real problem, if any, lies in the
kernel.

Comment 6 Arjan van de Ven 2001-03-13 10:19:37 UTC
mentioning the device on the commandline (iostat -x /dev/hde) seems to work
here, investigatin why it doesn't find them by default....

Comment 7 Arjan van de Ven 2001-03-13 10:59:15 UTC
The kernel was indeed not accounting "high" IDE channels. Fixed for our next
build.


Note You need to log in before you can comment on or make changes to this bug.