Bug 30553 - update fails on runing up2date
update fails on runing up2date
Status: CLOSED DUPLICATE of bug 29473
Product: Red Hat Linux
Classification: Retired
Component: up2date (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-04 10:18 EST by Marius Hjelle
Modified: 2015-01-07 18:44 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 13:59:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marius Hjelle 2001-03-04 10:18:46 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.


up2date -l exits w/ following output:
warning: can't access /etc/sysconfig/rhn/rhn
the file does not exsist.


Reproducible: Always
Steps to Reproduce:
1.login as root (su -l)
2.run up2date (let it update up2date)
3. re-run up2date (either x or nox)
	

Actual Results:  [root@funes /root]# up2date -l
warning: can't access /etc/sysconfig/rhn/rhn

Retrieving list of all available packages...
There was a fatal error communicating with the server.  The message was:

ERROR: Invalid Architecture and OS release combination
INFO : N/A

    An unexpected error has occured while processing your request.
    Please try again later or submit a bug report to rhns_help@redhat.com.
    If you choose to submit the bug report, please be sure to include
    details of what were you trying to do when this error occured and
    details on how to reproduce this problem.
    


Expected Results:  positive

[root@funes /root]# up2date -v
warning: can't access /etc/sysconfig/rhn/rhn
Red Hat Update Agent v2.3.2
Copyright (c) 1999-2001 Red Hat, Inc.
Licensed under terms of the GPL.
[root@funes /root]#
Comment 1 Marius Hjelle 2001-03-05 11:19:02 EST
reinstalling the original up2date package(s) to 2.3.1-1 will restore 
functionality.
Comment 2 Preston Brown 2001-03-06 00:34:37 EST
fixed in CVS (for next release).
Comment 3 Marius Hjelle 2001-03-08 08:51:52 EST
@last got the version 2.4
But: running up2date -l still gives me this output

ERROR: Invalid Architecture and OS release combination
INFO : N/A

    An unexpected error has occured while processing your request.
    Please try again later or submit a bug report to rhns_help@redhat.com.
    If you choose to submit the bug report, please be sure to include
    details of what were you trying to do when this error occured and
    details on how to reproduce this problem.
    
Comment 4 Jim Phillips 2001-03-08 13:59:10 EST
I can confirm this bug on mine as well.  Exact same conditions, exact same 
results.
Comment 5 Preston Brown 2001-03-14 17:22:31 EST

*** This bug has been marked as a duplicate of 29473 ***
Comment 6 Jay Turner 2001-03-15 08:53:09 EST
If you have the new up2date code (version 2.4) and are getting the "invalid
release/arch" message, what version of the release are you running (one of the
betas??)  The default site for up2date (www.rhns.redhat.com) does not have any
knowledge of the betas, and I bet that you are pointing up2date at those sites
and it is telling you that it has no clue what version of Red Hat Linux you are
running.  If you are indeed running one of the betas, then run 'up2date --config
--nox' and make sure that serverURL goes to
'https://beta.rhns.redhat.com/XMLRPC' and that should fix up the problem.

Note You need to log in before you can comment on or make changes to this bug.