Bug 305681 - execmem and execstack denied loading icedtea libjvm.so
Summary: execmem and execstack denied loading icedtea libjvm.so
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-25 17:34 UTC by Orion Poplawski
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 20:38:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Orion Poplawski 2007-09-25 17:34:58 UTC
Description of problem:

Trying to dlopen libjvm.so with octave:
 
octave:2> java_init
error: /usr/lib/jvm/jre/lib/i386/client/libjvm.so: cannot enable executable
stack as shared object requires: Permission denied

audit(1190740865.279:233): avc:  denied  { execstack } for  pid=23644
comm="octave" scontext=system_u:system_r:unconfined_t:s0
tcontext=system_u:system_r:unconfined_t:s0 tclass=process
audit(1190740865.279:234): avc:  denied  { execmem } for  pid=23644
comm="octave" scontext=system_u:system_r:unconfined_t:s0
tcontext=system_u:system_r:unconfined_t:s0 tclass=process

# ls -lZ /usr/lib/jvm/jre-1.7.0-icedtea/lib/i386/client/libjvm.so
-rwxr-xr-x  root root system_u:object_r:textrel_shlib_t
/usr/lib/jvm/jre-1.7.0-icedtea/lib/i386/client/libjvm.so

Version-Release number of selected component (if applicable):
selinux-policy-3.0.8-8.fc8

Comment 1 Daniel Walsh 2007-09-25 21:01:06 UTC
Looks like octave needs to be labeled java_exec_t.


Comment 2 Orion Poplawski 2007-09-25 21:13:11 UTC
Well, something does, but I'm not sure what.  octave is a C++ application.  In
this case though it is loading a package (shared library) that is in turn trying
to use libjvm.so.

Comment 3 Daniel Walsh 2007-09-25 21:18:30 UTC
Well we will label it a a java_exec_t in selinux-policy-3.0.8-14.fc8.src.rpm

Since this is the only way to add the execstack/execmem




Note You need to log in before you can comment on or make changes to this bug.