Bug 30571 - printconf-gui crashes immediately after start
printconf-gui crashes immediately after start
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: printconf (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Crutcher Dunnavant
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-04 15:25 EST by Markku Kolkka
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 10:04:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2001-03-04 15:25:18 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.14 i686)


Using printconf-gui-0.2-1, the window appears for a short time, then it
closes. Traceback info is printed to console.


Reproducible: Always
Steps to Reproduce:
1.login or su as root
2.run printconf-gui
3.
	

Actual Results:  Traceback  is displayed on console after program crashes.

Expected Results:  I expected to configure my printer.

Traceback:
# printconf-gui
Traceback (innermost last):
  File "/usr/sbin/printconf-gui", line 1823, in ?
    init_gui()
  File "/usr/sbin/printconf-gui", line 1809, in init_gui
    init_qld()
  File "/usr/sbin/printconf-gui", line 1457, in init_qld
    qld_display_queue_list()
  File "/usr/sbin/printconf-gui", line 1506, in qld_display_queue_list
    qld_display_queue(queue)
  File "/usr/sbin/printconf-gui", line 1527, in qld_display_queue
    q_description = gizmo_queue_description(queue)
  File "/usr/sbin/printconf-gui", line 366, in gizmo_queue_description
    details = _("%s queue on local device %s") % (f_blurb,
q_data.getChildByName('local_printer_device').getValue())
  File "/usr/lib/python1.5/site-packages/Alchemist.py", line 127, in
getChildByName
    name))
KeyError: No such child
Comment 1 sandy 2001-03-04 19:13:17 EST
You might try this (from bug 29170);

"Btw, I'm keeping the most recent printing rpms at:
 http://people.redhat.com/crutcher/printing"
Comment 2 Glen Foster 2001-03-05 15:46:57 EST
We (Red Hat) should really address this before the next release.
Comment 3 Tim Waugh 2001-03-06 10:04:22 EST
Was this an upgrade from Fisher, by any chance?  It looks like a beta->beta
upgrade thing to me.
Comment 4 Crutcher Dunnavant 2001-03-06 18:18:22 EST
This is a known beta->beta upgrade issue.
The newer printconf packages are smart enought to tell what they don't understand.

Note You need to log in before you can comment on or make changes to this bug.