Bug 30593 - Epson Stylus color 600 print failure
Summary: Epson Stylus color 600 print failure
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Crutcher Dunnavant
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-05 00:27 UTC by sandy
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-15 00:08:16 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description sandy 2001-03-05 00:27:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


After installing an Epson Stylus color 600 printer (using March 1, 2001
RPMS from  http://people.redhat.com/crutcher/printing/) I can print a text
file, but printing from;

Netscape halts printing after a good start (stalls in middle of first
page).

Gedit printing translates into garbage output on printer.

Reproducible: Always
Steps to Reproduce:
1.Install Epson Stylus color 600
2.Print from Netscape
3.Print from Gedit
	

Actual Results:  for 2. the printing stalls,
for 3. the printout is garbage

Expected Results:  normal printed output

Works same with wolverine and RPMS from
http://people.redhat.com/crutcher/printing/

Comment 1 Glen Foster 2001-03-05 20:47:04 UTC
We (Red Hat) should really address this before the next release.

Comment 2 Crutcher Dunnavant 2001-03-06 17:26:49 UTC
Is this a localy attached printer? There is some possibility that this is at
least partially a (recently solved) kernel issue. At least the stall part.

I will look into gedit.

Comment 3 keith adamson 2001-03-07 02:32:53 UTC
Printer is local connected to parallel port.

Can I help verify problem or install kernel patch?

Comment 4 Crutcher Dunnavant 2001-03-07 21:59:42 UTC
Hmm, just asked. That fix isn't in rawhide yet.

How long are the jobs you are trying to print?
Do the testpages in printconf-gui work?
Which driver are you using (and is it better with the other driver?)

Comment 5 sandy 2001-03-08 06:14:26 UTC
Jobs are 1-2 pages

printconf-gui text page prints OK.

printconf-gui postscript page hangs after about 1/5 page, the
printconf-gui  hangs as well, and ps -ef displays these jobs hanging;

lp        1091     1  0 00:19 ?        00:00:00 lpd Waiting  
lp        1657  1091  0 00:32 ?        00:00:00 lpd (Server) 'epson'
lp        1658  1657  0 00:32 ?        00:00:00 lpd (Worker - Print) 'epson'
lp        1659  1658  0 00:32 ?        00:00:00 [mf_wrapper <defunct>]
lp        1664     1  2 00:32 ?        00:00:00 gs -q -dBATCH -dSAFER -dQUIET
-dNOPAUSE -sDEVICE=stcolor -r360x360 -dnoWeave -sDithering=gscmyk
-sOutputCode=runlength -sOutputFile=- -
lp        1665  1664  4 00:32 ?        00:00:01 /usr/bin/perl
/usr/share/printconf/foomatic/mfomatic -d /var/spool/lpd/epson/stcolor-26016.foo

lpstat -t displays;

scheduler is running
system default destination: epson
printer epson unknown state. enabled since Mar 08 00:41 2001. available
Printer: epson@h00d0700074d1
 Queue: 1 printable job
 Server: pid 1657 active
 Unspooler: pid 1658 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at
00:32:57.996
 Rank   Owner/ID                  Class Job Files                 Size Time
stalled(503sec) root@h00d0700074d1+656 A 656 /usr/share/printcon 18043 00:32:55

cancel 656 unhangs everything except printconf-gui and ps -ef displays only;

lp        1091     1  0 00:19 ?        00:00:00 lpd Waiting  

kill printconf-gui and restart. change driver from stcolor to stp and apply and
reset printer.
printconf-gui text page prints OK,  printconf-gui postscript page hangs after
about 1/4 page, the
printconf-gui doesn't hang and ps -ef displays these jobs hanging (a couple line
trimmed,
my mistake, sorry);

lp        1760     1  0 00:48 ?        00:00:00 lpd Waiting  
lp        1777  1760  0 00:51 ?        00:00:00 lpd (Server) 'epson'
lp        1778  1777  0 00:51 ?        00:00:00 lpd (Worker - Print) 'epson'
lp        1779  1778  0 00:51 ?        00:00:00 [mf_wrapper <defunct>]
lp        1784     1  4 00:51 ?        00:00:05 gs -q -dSAFER -dNOPAUSE -dBATCH 
lp        1785  1784  1 00:51 ?        00:00:01 /usr/bin/perl /usr/share/printco

lpstat -t displays;

scheduler is running
system default destination: epson
printer epson unknown state. enabled since Mar 08 00:54 2001. available
Printer: epson@h00d0700074d1
 Queue: 1 printable job
 Server: pid 1777 active
 Unspooler: pid 1778 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at
00:51:09.401
 Rank   Owner/ID                  Class Job Files                 Size Time
stalled(221sec) root@h00d0700074d1+776 A 776 /usr/share/printcon 18043 00:51:08

cancel 776 unhangs everything and ps -ef displays only;

lp        1760     1  0 00:48 ?        00:00:00 lpd Waiting  

change driver from stp to stc600ih.upp and apply and reset printer.
printconf-gui text page prints OK,  printconf-gui postscript page hangs after
about 1/2 page
(redhat is now yellow on test page), the
printconf-gui doesn't hang and ps -ef displays these jobs hanging;

lp        1887     1  0 01:02 ?        00:00:00 lpd Waiting  
lp        1901  1887  0 01:02 ?        00:00:00 lpd (Server) 'epson'
lp        1902  1901  0 01:02 ?        00:00:00 lpd (Worker - Print) 'epson'
lp        1903  1902  0 01:02 ?        00:00:00 [mf_wrapper <defunct>]
lp        1908     1  2 01:02 ?        00:00:03 gs @stc600pl.upp -q -dBATCH
-dSAFER -dQUIET -dNOPAUSE -sOutputFile=- -
lp        1909  1908  2 01:02 ?        00:00:03 /usr/bin/perl
/usr/share/printconf/foomatic/mfomatic -d
/var/spool/lpd/epson/stc600ih.upp-26016.f

lpstat -t displays;

scheduler is running
system default destination: epson
printer epson unknown state. enabled since Mar 08 01:06 2001. available
Printer: epson@h00d0700074d1
 Queue: 1 printable job
 Server: pid 1901 active
 Unspooler: pid 1902 active
 Status: IF filter 'mf_wrapper' filter msg - 'closed *main::KID3' at
01:02:34.991
 Rank   Owner/ID                  Class Job Files                 Size Time
stalled(250sec) root@h00d0700074d1+900 A 900 /usr/share/printcon 18043 01:02:34

After this the printer did start for about another 1/4 page before hanging
again.
cancel 900 unhangs everything.



Comment 6 Crutcher Dunnavant 2001-03-09 21:39:53 UTC
I really think that this is a kernel issue.
I will notify you when the kernel that I think fixes this hits rawhide.

Comment 7 Tim Waugh 2001-03-13 15:50:29 UTC
Please try the -0.1.19 kernel (currently in rawhide).

Comment 8 sandy 2001-03-15 00:08:13 UTC
now works :o) !!!  Thanks


Note You need to log in before you can comment on or make changes to this bug.