Bug 30647 - MC's VFS doesn't work with locale != C
Summary: MC's VFS doesn't work with locale != C
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mc   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-05 15:11 UTC by Kjartan Maraas
Modified: 2007-04-18 16:31 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-07 21:11:12 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Diff for mc.ext (17.21 KB, patch)
2001-08-12 11:02 UTC, Kjartan Maraas
no flags Details | Diff
Diff for mc.ext (17.21 KB, patch)
2001-08-12 11:03 UTC, Kjartan Maraas
no flags Details | Diff
Diff for mc.ext (17.21 KB, patch)
2001-08-12 11:04 UTC, Kjartan Maraas
no flags Details | Diff
Diff for mc.ext (17.21 KB, patch)
2001-08-12 11:08 UTC, Kjartan Maraas
no flags Details | Diff
Diff for mc.ext (17.21 KB, patch)
2001-08-12 11:09 UTC, Kjartan Maraas
no flags Details | Diff

Description Kjartan Maraas 2001-03-05 15:11:51 UTC
Unless I start mc with 'LC_ALL=C mc' I can't use it's VFS
capabilities.

Hit F3 on a gzipped textfile; hangs
Press enter on a RPM; garbage-spew on screen

Cheers

Comment 1 Glen Foster 2001-03-05 20:45:38 UTC
This defect considered a show-stopper (MUST-FIX) for Florence GOLD release

Comment 2 Jonathan Blandford 2001-03-05 21:15:36 UTC
I can't duplicate this at all.  Does it not work with all .tar.gz files, or just
one?

Comment 3 Kjartan Maraas 2001-03-06 10:42:48 UTC
It looks like something is trying to open archives as man pages. If I rename the
.rpm file so it has no numbers in it, it opens just fine. Could this be some
strange MIME interaction?

Comment 4 Kjartan Maraas 2001-03-06 10:54:20 UTC
This has been found to be a bug in gnome-vfs' mime handling. There was a regexp
that included nearly all files in the entry for troff.



Comment 5 Kjartan Maraas 2001-03-07 15:12:18 UTC
I have a clue now. I tested this for no_NO and da_DK and it is broken. For some
other locales (de_DE) for instance it works. After commenting out the regexps
for troff in /usr/lib/mc/mc.ext it works for me again. So the question is why
these regexps are expanded differently according to locale....

Reopened.

Cheers
Kjartan

Comment 6 Preston Brown 2001-03-13 19:44:54 UTC
worked around in mc-4.5.51-29 and later.


Comment 7 Kjartan Maraas 2001-08-12 11:02:32 UTC
Created attachment 27434 [details]
Diff for mc.ext

Comment 8 Kjartan Maraas 2001-08-12 11:03:56 UTC
Created attachment 27435 [details]
Diff for mc.ext

Comment 9 Kjartan Maraas 2001-08-12 11:04:29 UTC
Created attachment 27436 [details]
Diff for mc.ext

Comment 10 Kjartan Maraas 2001-08-12 11:08:15 UTC
Created attachment 27437 [details]
Diff for mc.ext

Comment 11 Kjartan Maraas 2001-08-12 11:09:40 UTC
Created attachment 27438 [details]
Diff for mc.ext

Comment 12 Kjartan Maraas 2001-08-12 11:10:09 UTC
I wonder if this was really caused by the regexp.c problems in glibc at the
time. Trying the Red Hat mc package with the mc.ext file from mc in CVS works
wonderfully now. Attaching a diff to bring the Red Hat version up to date.

Comment 13 Kjartan Maraas 2001-08-12 11:11:53 UTC
Hmmm. Sorry for the multiple attachments. Mozilla hung on submitting them so I
figured it hadn't gone through. Will file this as a bug though. It just sat
there and CPU usage went to 98%.

Well, reopening this bug too.


Comment 14 Havoc Pennington 2002-03-04 17:55:50 UTC
What is the remaining issue here? Is it fixed in upstream mc latest version do
you think?

Comment 15 Kjartan Maraas 2002-03-04 21:08:16 UTC
I think this was a bug in glibc that was fixed before the final 7.2 release.
Remove the band aid and let me try?


Comment 16 Havoc Pennington 2002-03-04 21:28:17 UTC
Will do when I upgrade the mc package.

Comment 17 Havoc Pennington 2002-03-07 21:11:06 UTC
I'm building the package now for testing.

Comment 18 Havoc Pennington 2002-03-18 17:26:29 UTC
Assuming this works....

Comment 19 Kjartan Maraas 2002-03-18 19:14:03 UTC
Right you are... :)


Note You need to log in before you can comment on or make changes to this bug.