Bug 30651 - ATI rage mobility (mach64) laptop cannot run X when connected to a external monitor
ATI rage mobility (mach64) laptop cannot run X when connected to a external m...
Status: CLOSED DUPLICATE of bug 27148
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 10:56 EST by Chris Runge
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-17 15:37:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log using anaconda-generated config file (20.23 KB, text/plain)
2001-03-05 10:57 EST, Chris Runge
no flags Details
log generated from Xconfigurator-generated config file (19.18 KB, text/plain)
2001-03-05 10:58 EST, Chris Runge
no flags Details
log generated during Xconfigurator test (19.45 KB, text/plain)
2001-03-05 11:01 EST, Chris Runge
no flags Details
anaconda-generated config file (3.69 KB, text/plain)
2001-03-05 11:03 EST, Chris Runge
no flags Details
config file generated by Xconfigurator (1.84 KB, text/plain)
2001-03-05 11:04 EST, Chris Runge
no flags Details

  None (edit)
Description Chris Runge 2001-03-05 10:56:24 EST
7.1 RC2

hardware:
- Dell Latitude CPx (8MB Rage Mobility)
- externel Dell 19in monitor

problem:
X works great when the PC is not connected to an external monitor; when
connected to the monitor it refuses to start and complains about a lack of
valid screens. This problem did not exist under RHL7. X works when the
external monitor is not attached.

background:
install was done using pcmcia.img and NFS. The machine was connected to the
external monitor at the time via a docking station. The graphical
installation (default) was chosen and worked well. I noticed, however,
during the X configuration phase that it detected the flat panel instead of
the attached Dell monitor. The X test failed (or more properly the screen
blanked and then returned to the X configuration screen).

Post-install "startx" failed with an error about a lack of valid screens.

I then ran Xconfigurator. Xconfigurator detected the attached Dell monitor.
I selected for possible resolutions 1024x768, 800x600, 640x480, all at
8bpp, 16bpp, and 24bpp. The test failed.

Exiting Xconfigurator "startx" failed again with a similar error.

Attachments (to be included):
- XFree86.0.log-orig [the log from the original "startx" attempt post-install]
- XFree86.9.log-Xconfigurator [the log generated during the Xconfigurator
attempt post-install]
- XFree86.0.log-postXconfigurator [the log from the "startx" attempt
post-Xconfigurator]
- XF86Config-4.orig [the original XF86Config-4 file generated by anaconda]
- XF86Config-4.xconfigurator-monitor [the XF86Config-4 file generated by
Xconfigurator]

Notes:
- the XF86Config-4 file generated by Xconfigurator has some problems with
it (it added 1600x1200 as a possible resolution for 24 and 16bpp, but not
8bpp--this resolution was not chosen)
Comment 1 Chris Runge 2001-03-05 10:57:31 EST
Created attachment 11802 [details]
log using anaconda-generated config file
Comment 2 Chris Runge 2001-03-05 10:58:36 EST
Created attachment 11803 [details]
log generated from Xconfigurator-generated config file
Comment 3 Chris Runge 2001-03-05 11:01:28 EST
Created attachment 11804 [details]
log generated during Xconfigurator test
Comment 4 Chris Runge 2001-03-05 11:03:45 EST
Created attachment 11805 [details]
anaconda-generated config file
Comment 5 Chris Runge 2001-03-05 11:04:37 EST
Created attachment 11806 [details]
config file generated by Xconfigurator
Comment 6 Mike A. Harris 2001-03-12 23:03:57 EST
What release of XFree86 are you using for all of this? If you aren't allready,
please try XFree86-4.0.2-11.4.0, Mesa-3.4-11 and the latest rawhide kernel.
Does this fix it for you?
Comment 7 Mike A. Harris 2001-03-17 15:37:42 EST
Ok, we are looking into this and corelating it with other similar bug reports.
Comment 8 Mike A. Harris 2001-03-17 15:42:02 EST

*** This bug has been marked as a duplicate of 27148 ***

Note You need to log in before you can comment on or make changes to this bug.