Bug 30658 - Installer hangs if custom script mounts a loopback device
Installer hangs if custom script mounts a loopback device
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 11:49 EST by mohammed f khan
Modified: 2007-04-18 12:31 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-06 13:42:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mohammed f khan 2001-03-05 11:49:12 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0b; Windows NT 5.1)


The problem is that if file is mounted to a directory via the loopback 
device... the partition that this file and directory reside on cannot be 
unmounted, hence the install wont complete because there   partition 
remains mounted... 

                     

Reproducible: Always
Steps to Reproduce:
	For eg.: 

                                        # 
mkdir /mnt/dos                        # make a directory in /mnt 
                                        # mount -t 
vfat /dev/sda2 /mnt/dos      # mount a dos partition that has the RedHat 
Cd copied to it 

                                        # 
cd /mnt/dos/autoboot                  # switch to a dir within that 
partition                 

                                        # mkdir 
temp                            # mount the initrd.img that is here 
                                        # mv initrd.img initrd.gz 
                                        # gzipd -d initrd.gz 
                                        # mount initrd temp -o loop     
(this operation cause /dev/sda2 to go busy forever.. it will now refuse to 
unmount)

                                        # cd temp               
                                        ... do some stuff in temp ... 
                                        # cd .. 
                                        # umount 
temp                           # unmount and cleanup 
                                        # rm -rf temp 
                                        # 
cd /                                  # get out of mounted dir 
                                        # umount /dev/sda2 
(or /mnt/dos)                (this operation will return an error saying 
that /dev/sda2 is busy...)

        The same problem occurs when you mount a file that is on the cdrom 
during install via loopback and then try to unmount... it makes the cdrom 
busy.. hence the cdrom wont eject at the completion of RedHat      
install.               


Actual Results:  if the file mounted as loopback was on cd.. the cd will 
not eject anymore.. or if it were on a harddisk partition.. that partition 
will not unmount...

Expected Results:  partition/cdrom should eject fine because there should 
not be any thing keeping them busy.
Comment 1 Matt Wilson 2001-03-05 15:02:20 EST
this would be a kernel problem with usage count, perhaps.  Not an anaconda bug.
Comment 2 Michael K. Johnson 2001-03-12 12:33:41 EST
I believe this to be fixed in the errata kernel.  Please reopen
this bug report if this is not the case.

Note You need to log in before you can comment on or make changes to this bug.