Bug 30674 - Xconfigurator with NeoMagic 256AV doesn't default to XFree4
Xconfigurator with NeoMagic 256AV doesn't default to XFree4
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Preston Brown
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-05 14:15 EST by Matt Domsch
Modified: 2007-04-18 12:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 13:00:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Domsch 2001-03-05 14:15:59 EST
Running Florence RC2 with a Dell Latitude CPiA laptop, Neomagic NM256AV
video controller.  

Xconfigurator runs and says:
PCI entry: Neomagic Corporation|[MagicMedia 256AV]
X server: XF86_SVGA
XFree4 Driver: neomagic (not used by default)

Since XFree3 isn't being shipped with Florence, this fails, with:
Server doesn't exist, can't continue
tried to use ../../usr/X11R6/bin/XF86_SVGA

You must run Xconfigurator --preferxf4  to make this work.  Since XFree3
isn't an option any more, it should default to the XFree4 server (which
works fine).
Comment 1 Glen Foster 2001-03-05 15:45:46 EST
This defect considered a show-stopper (MUST-FIX) for Florence GOLD release
Comment 2 David Lawrence 2001-03-05 16:06:30 EST
Have tested this with a NM2160 MagicGraph 128XD in a DEC VPNote Laptop. I also
noticed that
the XFree86 3.3.6 server is being used instead of the 4.0.2. I ran Xconfigurator
--preferxf4 and reconfigured X to use the 4.0.2 driver with no problems.
Comment 3 Bill Nottingham 2001-03-05 17:20:34 EST
XFree86 3 isn't being shipped in Florence????

That's news to me....
Comment 4 Matt Domsch 2001-03-05 17:37:37 EST
An "Everything" install of RC1 shows XFree86-FBDev-3.3.6-33 as the only 3.3.6 
RPM installed...
Comment 5 Bill Nottingham 2001-03-05 23:16:04 EST
That would be a different bug. :)
The SVGA X server is still there.
Comment 6 Bill Nottingham 2001-03-05 23:16:36 EST
I'm assuming this was a text mode install?
Comment 7 Matt Domsch 2001-03-05 23:18:48 EST
kickstart skipx (thus, text-mode), yes.
Comment 8 Tim Waugh 2001-03-06 10:02:09 EST
I've seen this too, but the problem is that even when you install the 3.3.6 SVGA
server, Xconfigurator says 'there was a problem with..'.

XFree86-4.0.2-11
Xconfigurator-4.9.16-1
Comment 9 Preston Brown 2001-03-08 13:00:49 EST
fixed up Xconfigurator to use XF 4.x drivers for NeoMagic 128 and 256 chips.

Version 4.9.18 and later.

Note You need to log in before you can comment on or make changes to this bug.