Bug 30674 - Xconfigurator with NeoMagic 256AV doesn't default to XFree4
Summary: Xconfigurator with NeoMagic 256AV doesn't default to XFree4
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
Target Milestone: ---
Assignee: Preston Brown
QA Contact: David Lawrence
Depends On:
TreeView+ depends on / blocked
Reported: 2001-03-05 19:15 UTC by Matt Domsch
Modified: 2007-04-18 16:31 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-08 18:00:53 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

Description Matt Domsch 2001-03-05 19:15:59 UTC
Running Florence RC2 with a Dell Latitude CPiA laptop, Neomagic NM256AV
video controller.  

Xconfigurator runs and says:
PCI entry: Neomagic Corporation|[MagicMedia 256AV]
X server: XF86_SVGA
XFree4 Driver: neomagic (not used by default)

Since XFree3 isn't being shipped with Florence, this fails, with:
Server doesn't exist, can't continue
tried to use ../../usr/X11R6/bin/XF86_SVGA

You must run Xconfigurator --preferxf4  to make this work.  Since XFree3
isn't an option any more, it should default to the XFree4 server (which
works fine).

Comment 1 Glen Foster 2001-03-05 20:45:46 UTC
This defect considered a show-stopper (MUST-FIX) for Florence GOLD release

Comment 2 David Lawrence 2001-03-05 21:06:30 UTC
Have tested this with a NM2160 MagicGraph 128XD in a DEC VPNote Laptop. I also
noticed that
the XFree86 3.3.6 server is being used instead of the 4.0.2. I ran Xconfigurator
--preferxf4 and reconfigured X to use the 4.0.2 driver with no problems.

Comment 3 Bill Nottingham 2001-03-05 22:20:34 UTC
XFree86 3 isn't being shipped in Florence????

That's news to me....

Comment 4 Matt Domsch 2001-03-05 22:37:37 UTC
An "Everything" install of RC1 shows XFree86-FBDev-3.3.6-33 as the only 3.3.6 
RPM installed...

Comment 5 Bill Nottingham 2001-03-06 04:16:04 UTC
That would be a different bug. :)
The SVGA X server is still there.

Comment 6 Bill Nottingham 2001-03-06 04:16:36 UTC
I'm assuming this was a text mode install?

Comment 7 Matt Domsch 2001-03-06 04:18:48 UTC
kickstart skipx (thus, text-mode), yes.

Comment 8 Tim Waugh 2001-03-06 15:02:09 UTC
I've seen this too, but the problem is that even when you install the 3.3.6 SVGA
server, Xconfigurator says 'there was a problem with..'.


Comment 9 Preston Brown 2001-03-08 18:00:49 UTC
fixed up Xconfigurator to use XF 4.x drivers for NeoMagic 128 and 256 chips.

Version 4.9.18 and later.

Note You need to log in before you can comment on or make changes to this bug.