Bug 307551 - Several menu options are nonfunctional
Summary: Several menu options are nonfunctional
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
medium
Target Milestone: ---
Assignee: Daniel Berrange
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-26 18:05 UTC by Zack Cerza
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 02:32:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Zack Cerza 2007-09-26 18:05:37 UTC
Description of problem:
Summary says it all.

Version-Release number of selected component (if applicable):
virt-manager-0.5.0-1.fc8

Comment 1 Zack Cerza 2007-09-26 18:18:23 UTC
Hmm, also 'Delete Machine' and 'Help' do nothing.

Comment 2 Zack Cerza 2007-09-27 19:53:58 UTC
OK, I've found another menu item that isn't working. I'll summarize them right
now just to be clear, and let me know if you think separate reports should be
opened. I'm thinking maybe there's a common cause for this breakage:

In the Virtual Machine Manager:
Help -> Contents
Edit -> Delete Machine

In the Virtual Machine Console:
Virtual Machine -> Pause
View -> Full Screen
Help -> Contents

are all nonfunctional.

Comment 3 Daniel Berrange 2007-09-27 21:44:33 UTC
Do you have  'yelp' installed. If not, the non-functional  Help menu si
expected. We don't have an RPM dep on yelp since Fedora guidelines say its
optional & it avoids pulling in all GNOME stack for people who just want
virt-manager on its own.

Confirmed that Delete & Pause are broken.

Full screen is fixed upstream

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=fd3ce799a87e

Comment 4 Zack Cerza 2007-09-27 22:02:05 UTC
Ah, yeah, I bet yelp isn't installed.

So do you want extra bugs filed to keep these issues separate, or is one enough?

Comment 5 Daniel Berrange 2007-09-27 23:39:45 UTC
Don't bother with extra bugs - I'll be able to fix these issues in less time
than it'll take to enter extra bugs :-)


Comment 7 Daniel Berrange 2007-10-05 02:32:35 UTC
These are all addressed in rawhide with virt-manager-0.5.2


Note You need to log in before you can comment on or make changes to this bug.