Bug 307631 - MangeAgents doesn't work as expected
MangeAgents doesn't work as expected
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: webalizer (Show other bugs)
5.1
All Linux
low Severity low
: ---
: ---
Assigned To: Joe Orton
qe-baseos-daemons
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-26 14:37 EDT by Vilius Šumskas
Modified: 2013-01-23 07:24 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-23 07:24:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vilius Šumskas 2007-09-26 14:37:40 EDT
Description of problem:
MangleAgents doesn't work as excepted. For example I have set it to 4 and some 
of the user agent strings are displayed recursively. Example:
16 49827 0.12% Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; 
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2. 
17 43045 0.11% Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; 
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ) 
18 42203 0.11% Opera/8.0 
19 41154 0.10% MSIE 5.5 
Note double "compatible" ant "MSIE" strings.

Version-Release number of selected component (if applicable):
webalizer-2.01_10-30.1

How reproducible:
Always

Steps to Reproduce:
1. Set MangleAgents in webalizer.conf to 4.
2. Wait for the cron script to update data.
  
Actual results:
16 49827 0.12% Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; 
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ; .NET CLR 2. 
17 43045 0.11% Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; 
Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1) ) 
18 42203 0.11% Opera/8.0 
19 41154 0.10% MSIE 5.5 

Expected results:
16 99827 0.23% MSIE 6.0
18 42203 0.11% Opera/8.0 
19 41154 0.10% MSIE 5.5 


Additional info:
This began to happen after one of these patches:
* Sat Jun 17 2006 Joe Orton <jorton@redhat.com> 2.01_10-30
- add patch set from Jarkko Ala-Louvesniemi (#187344, #187726, #188248)
Comment 1 Jan Kaluža 2013-01-23 07:24:06 EST
I was able to reproduce this bug in RHEL5, but it looks like it is already fixed in RHEL6. It's unlikely that this bug will be fixed in RHEL5, so I'm closing this bug as CLOSED CURRENTRELEASE.

Note You need to log in before you can comment on or make changes to this bug.