Bug 308071 - quilt does not work in rawhide
Summary: quilt does not work in rawhide
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: quilt   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Josh Boyer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 291081 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-26 20:56 UTC by Rik van Riel
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-01 12:40:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rik van Riel 2007-09-26 20:56:20 UTC
Description of problem:

I simply type "quilt push" and it starts complaining about an option I did not
even type in...

$ quilt push
illegal option: color at /usr/share/quilt/compat/getopt line 104.
Usage: quilt push [-afqv] [--leave-rejects] [--interactive]
[--color[=always|auto|never]] [num|patch]

Version-Release number of selected component (if applicable):

quilt-0.46-3.fc8

How reproducible:

Try using quilt.

Comment 1 Rik van Riel 2007-09-26 21:03:13 UTC
Commenting out the --color=auto bits in /etc/quilt.quiltrc seems to make it work
again.  Funky.

This is on a system with a fresh install and the /etc/quilt.quiltrc from the rpm...

Comment 2 Josh Boyer 2007-09-27 10:58:52 UTC
Looks like bug 291081 which I also haven't figured out yet.  I'll try looking at 
this today.

Comment 3 Josh Boyer 2007-09-28 00:01:27 UTC
This appears to be /usr/share/quilt/compat/getopt not coping well with having an
option with :: after it.  If I change the push script to use just 'color:'
things work fine.

My perl and regex sucks, but I'll keep poking at it.

Comment 4 Andreas Gruenbacher 2007-09-28 07:18:37 UTC
/usr/share/quilt/compat/getopt is a pretty weak replacement for the system 
getopt, for systems that don't have getopt. Please check why /usr/bin/getopt 
from util-linux isn't present at build time.

Comment 5 Josh Boyer 2007-09-28 11:08:06 UTC
(In reply to comment #4)
> /usr/share/quilt/compat/getopt is a pretty weak replacement for the system 
> getopt, for systems that don't have getopt. Please check why /usr/bin/getopt 
> from util-linux isn't present at build time.

AH!  That's because for rawhide (and F8) util-linux was replaced by
util-linux-ng and it was dropped from the default build root for a while.  I'll
add a BR on util-linux-ng and rebuild it.

Thanks Andreas!

Comment 6 Eric Sandeen 2007-09-28 13:31:21 UTC
*** Bug 291081 has been marked as a duplicate of this bug. ***

Comment 7 Josh Boyer 2007-09-29 12:26:45 UTC
http://koji.fedoraproject.org/koji/buildinfo?buildID=19809

The above build works for me.  I'll ask rel-eng to include it in rawhide.

Comment 8 Josh Boyer 2007-11-01 12:40:12 UTC
Oops.  This was fixed a while ago.


Note You need to log in before you can comment on or make changes to this bug.