Bug 30813 - Installer crashed during upgrade and new installation
Installer crashed during upgrade and new installation
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Brent Fox
Brock Organ
N/A
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-06 10:20 EST by Thomas Chao
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 13:33:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Chao 2001-03-06 10:20:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (WinNT; U)


Installer will crashed and exit by itself during initial boot-up.  The machine is originally running V.7 fine.

Reproducible: Always
Steps to Reproduce:
1. Power up the PC.
2. Put in Fisher CD to boot into Linux installer
3. The installer exited by itself and crashed.
	

Actual Results:  The PC crashed and random texture running all over the screen and the PC lock up.

Expected Results:  It should starts the Linux installation process.

The machine is running RH 7 fine before this test.
I believe the problem may be due to ananconda run-time running on Matrox Millnenium G200 Graphics card.
Comment 1 Brent Fox 2001-03-06 12:42:45 EST
Here's a couple of things to try:
1) At the bootup screen, say 'nofb'.  Does this change anything?
2) At the bootup screen, say 'lowres'.  Any difference?
3) Does text mode install work?
Comment 2 Thomas Chao 2001-03-06 14:04:00 EST
I have tried all the possible mode: text, graphics, nofb, lowres.  They all 
failed after starting ananconda.  The difference in graphics mode is that it 
will stop after a whole screen of random characters.

When I use RH 7 CD to test it, everything runs fine.  Therefore, confirming 
that PC is OK.
Comment 3 Glen Foster 2001-03-06 15:53:23 EST
What happens if you try Wolverine, the latest public beta?  It would help us a
lot for you to try the newer code -- lots of fixes are in it compared to
Fisher.  It's available on the ftp site and several mirrors world-wide.
Comment 4 Glen Foster 2001-03-06 16:13:56 EST
We (Red Hat) should really try to fix this before next release.
Comment 5 Brent Fox 2001-03-06 16:51:10 EST
Sounds to me like you either have a bad cd, or there is a really bad kernel bug
that manifests itself on your particular hardware.  Since text mode doesn't
work, the issue is not related to the video card.  I can't think of a reason for
the installer just to not boot.  Can you try that cd on another machine and see
if it boots there?
Comment 6 Thomas Chao 2001-03-07 08:44:54 EST
no, I do not think this is a problem of bad CD or hardware, since current RH 7 
and Slackware 7.1 can install fine!  The installer crash only after booting 
into ananconda run-time!

I have downloaded the Wolverine Beta and tested twice last night, this is my 
findings:

- The installer is now fixed, but not stable.  For example, in the fb boot to 
graphics mode, the first time it was boot the fb text mode.  The second time it 
runs fine and I was able to install the new OS.  Also, the fb screen is a kind 
of weird sized screen that I have to adjust it.

- (This is nothing to do with this bug report, but I will include for your 
ref.)  Running into X is fine, but was very slow running in KDE 2.0 and when I 
exit, it exit to text mode, not the X login screen.  When I reboot, I got a 
totally blank screen.  I was able to restart into level 3 text mode again, but 
running X, still in blank screen.  

I do not have any problem with another video card (on the other machine that I 
do testing).  I will test again using this ATI AGP card.
Comment 7 Thomas Chao 2001-03-07 08:46:12 EST
no, I do not think this is a problem of bad CD or hardware, since current RH 7 
and Slackware 7.1 can install fine!  The installer crash only after booting 
into ananconda run-time!

I have downloaded the Wolverine Beta and tested twice last night, this is my 
findings:

- The installer is now fixed, but not stable.  For example, in the fb boot to 
graphics mode, the first time it was boot the fb text mode.  The second time it 
runs fine and I was able to install the new OS.  Also, the fb screen is a kind 
of weird sized screen that I have to adjust it.

- (This is nothing to do with this bug report, but I will include for your 
ref.)  Running into X is fine, but was very slow running in KDE 2.0 and when I 
exit, it exit to text mode, not the X login screen.  When I reboot, I got a 
totally blank screen.  I was able to restart into level 3 text mode again, but 
running X, still in blank screen.  

I do not have any problem with another video card (on the other machine that I 
do testing).  I will test again using this ATI AGP card.  I will let you know 
my findings.
Comment 8 Brent Fox 2001-03-07 11:14:33 EST
When I said that I think you have a bad cd, I mean that perhaps something is
wrong with the particular cd-rom that Fisher was on.  It could have bad sectors,
or something could have gone wrong when the data was being copied to the cd.
Even though Red Hat Linux 7 and Slackware install fine...this has nothing to do
with whether the cd that Fisher is on is good or not.
Comment 9 Brent Fox 2001-03-07 11:19:01 EST
The frame buffer screen is 800x600 resolution.  You may need to adjust your
monitor if you usually run higher resolutions.  Can you do an MD5sum on the
Wolverine iso images that you downloaded and verify that they are correct?
Also, what video card are you seeing the strange behavior on?
Comment 10 Thomas Chao 2001-03-08 13:33:12 EST
This is my new findings last night.  I tested again with another two video 
cards.  The details are:

1. Dimonad Viper, TNT 2 chip w/ 16 MB (OEM for HP):  Installer running OK.  Has 
some video glitch, but is chip known problem, nothing to do with RH Installer.

2. ATI Rage 128 AGP w/ 32 MB.  Running fine.

I also test the Installer on another machine w/ S3 Virge chipset and it is 
runnng fine.

Again, it only crashed when I am using Matrox Millnenium G200 (OEM).
Comment 11 Brent Fox 2001-03-08 15:39:27 EST
I did installs of the latest tree and Wolverine with my Matrox G200 with no
problems.  We have recently reverted the Matrox default from XFree 4 to XFree 3,
so hopefully whatever issues you are seeing are caused by XFree 4.  However,
that doesn't explain why XFree 4 works fine for me with the Matrox G200.  I'm
resolving as rawhide, but please reopen if the bug persists in the future.
Thanks for your report.

Note You need to log in before you can comment on or make changes to this bug.