Bug 308681 - missing dependency for kmod-sysprof in updated version
Summary: missing dependency for kmod-sysprof in updated version
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sysprof-kmod   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Gianluca Sforna
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-27 10:10 UTC by Jos van den Oever
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version: 1.0.8-1.2.6.22.9_91.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-04 20:00:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jos van den Oever 2007-09-27 10:10:26 UTC
Description of problem:
On 64 bit linux, the kernel module for sysprof cannot be updated because of a 
missing dependency:

Error: Missing Dependency: kernel-x86_64 = 2.6.22.5-76.fc7 is needed by 
package kmod-sysprof

Version-Release number of selected component (if applicable):
kernel.x86_64 0:2.6.22.7-85.fc7
kmod-sysprof.x86_64 0:1.0.8-1.2.6.22.5_76.fc7


How reproducible:
always

Steps to Reproduce:
1. yum clean all
2. yum update kmod-sysprof
  
Actual results:
--> Finished Dependency Resolution
Error: Missing Dependency: kernel-x86_64 = 2.6.22.5-76.fc7 is needed by 
package kmod-sysprof

Comment 1 Jarod Wilson 2007-09-27 18:44:18 UTC
Not a kernel bug, but rather an illustration of why kmod packages suck. The
"missing" dependency is provided by an older kernel than the latest one in the
updates repo. What's needed is a newer kmod-sysprof. Reassigning to sysprof
component.

Comment 2 Gianluca Sforna 2007-09-27 22:25:01 UTC
I submitted the proper update for sysprof-kmod so you should be able to update
it as soon as the package reaches the mirrors.

Sorry for the trouble

Comment 3 Gianluca Sforna 2007-10-04 20:00:42 UTC
And it was just pushed to -updates


Note You need to log in before you can comment on or make changes to this bug.