Bug 308861 - Bootup Problems - Unable to access resume drive
Bootup Problems - Unable to access resume drive
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 08:37 EDT by my_linux
Modified: 2008-01-23 08:48 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.6.23.9-85.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-23 03:32:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (42.62 KB, text/plain)
2008-01-16 17:20 EST, my_linux
no flags Details
dmidecode (7.05 KB, text/plain)
2008-01-16 17:21 EST, my_linux
no flags Details
dmesg (23.17 KB, text/plain)
2008-01-16 17:21 EST, my_linux
no flags Details
dmesg (23.77 KB, text/plain)
2008-01-17 15:09 EST, my_linux
no flags Details

  None (edit)
Description my_linux 2007-09-27 08:37:57 EDT
Description of problem:
Acer Aspire A7520 notebook related issue.

Partitions as follows on 80GB SATA HDD:

sd1 = /
sd2 = /Data
sd3 = swap

x86 Live CD: I need to set acpi=off and noapic to boot.

x86_64 Live CD: Boots with out additional kernel settings.

In both cases there is an intermittent error message (more frequent in x86) 
that forces me to have to shutdown the notebook. The error occurs during 
initial boot sequence as follows:

Red Hat nash version 6.0.9 starting
Unable to access resume drive (Label=swap-sd3)
Mount: Could not find filesystem '/dev/root'
Setuproot: Moving /dev/failed: No such file or directory
Setuproot: Error mounting proc: No such file or directory
Setuproot: Error mounting sys: No such file or directory
Switchroot: Mount failed: No such file or directory
Kernel panic - not syncing: Attempted to kill init!

Version-Release number of selected component (if applicable):
N/A

How reproducible:
Often on bootup from cold. Sometimes on reboot. Delaying bootup can help but 
not always.

Steps to Reproduce:
1. As above
2.
3.
  
Actual results:


Expected results:


Additional info:
I have posted to Fedora forums but no solution presented.
Comment 1 my_linux 2007-09-27 10:53:00 EDT
Unfortunaetly I am no expert so I may be wrong that this is a kernel related 
issue if you think this is the case please advise what to do next.

Thanks
Comment 2 my_linux 2007-09-28 03:38:32 EDT
Does the newly released kernel ending 85 resolve issues like this?
Comment 3 my_linux 2007-10-08 03:00:50 EDT
I have noticed after re-installing Fedora 7 x86_64 again that the grub.conf file
is imho wrongly set and is possibly what is causing my boot problems? The
default after installing from a USB stick this time is as follows:

# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE: You do not have a /boot partition. This means that
# all kernel and initrd paths are relative to /, eg.
# root (hd0,0)
# kernel /boot/vmlinuz-version ro root=/dev/sda1
# initrd /boot/initrd-version.img
#boot=/dev/sda
default=0
timeout=5
splashimage=(hd0,0)/boot/grub/splash.xpm.gz
hiddenmenu
title Fedora (2.6.21-1.3194.fc7)
root (hd0,0)
kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro root=LABEL=/1 rhgb quiet
initrd /boot/initrd-2.6.21-1.3194.fc7.img

Now when I change the line kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro
root=LABEL=/1 rhgb quiet to kernel /boot/vmlinuz-2.6.21-1.3194.fc7 ro
root=/dev/sda1 rhgb quiet Fedora does boot up other wise it is the error as above.

Could this be an Anaconda problem?
Comment 4 my_linux 2007-10-08 03:02:34 EDT
or grub problem?
Comment 5 my_linux 2007-10-08 07:09:55 EDT
Changing the grub entry does not work :(
Comment 6 Christopher Brown 2008-01-13 21:26:53 EST
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug and will try and assist you in resolving it if I can.

There hasn't been much activity on this bug for a while. Could you tell me if
you are still having problems with the latest kernel?

If the problem no longer exists then please close this bug or I'll do so in a
few days if there is no additional information lodged.
Comment 7 my_linux 2008-01-14 01:00:40 EST
Hi there,

the problem is on-going with Fedora 7 / 8 with updates applied.

I have checked the labels associated with the partitions and created a new 
initrd file but this has made no difference.

When the computer boots up there are no problem and everything just works fine 
or appears to do so.
Comment 8 my_linux 2008-01-14 01:06:36 EST
What I mean is when the computer boots up correctly there are no problems.
Comment 9 my_linux 2008-01-14 01:15:37 EST
I have posted a lot of info to fedoraforum.org with username my_linux. You may 
wish to refer to that too.
Comment 10 Christopher Brown 2008-01-14 07:59:01 EST
Can you post the contents of /etc/fstab following a successful boot. Also
updated grub.conf would be appreciated. Both are short files so copy and paste
inline will be fine.
Comment 11 my_linux 2008-01-14 15:08:49 EST
The grub.conf is the same as above but with the root label changed from /1 to /.
Bear in mind a boot can occur with /1 too. I  don't think it matters which it
is, I did make a new initrd after changing the label.

LABEL=/                 /                       ext3    defaults        1 1
LABEL=/Data             /Data                   ext3    defaults        1 2
tmpfs                   /dev/shm                tmpfs   defaults        0 0
devpts                  /dev/pts                devpts  gid=5,mode=620  0 0
sysfs                   /sys                    sysfs   defaults        0 0
proc                    /proc                   proc    defaults        0 0
LABEL=SWAP-sda3         swap                    swap    defaults        0 0

I have also tried changing the way the swap and other drives were shown by using
/dev/sda... and updating the initrd. The same problem still occurs.
Comment 12 my_linux 2008-01-14 15:11:26 EST
The fstab is what is seen after I have edited the /1 to /. For sure I have made
the appropriate changes when using /dev/sdaa... instead of labels.
Comment 13 my_linux 2008-01-15 03:37:38 EST
The following link covers some of the things I have done.

http://fedoraforum.org/forum/showthread.php?t=168204
Comment 14 my_linux 2008-01-15 03:43:09 EST
The problem does not appear to be specifc to Fedora as Mandriva and Cent OS 
suffer the same issue.

However, openSUSE, Sabayon 3.4 Live do boot up reliably. I have made note of 
some of the differences on the above link. You might want to look at the 
Sabayon site which lists the kernel config.
Comment 15 Christopher Brown 2008-01-15 19:47:25 EST
Can you please attach the following (try and get these from a reliable Fedora
boot if at all possible) as separate attachments of type text/plain:

# dmidecode
lspci -vvxxx
dmesg

I will then re-assign to relevant maintainer who may be able to shed some more
light on the issue. You may also wish to check for a BIOS upgrade at:

http://support.acer-euro.com/drivers/notebook/as_7520.html

with the usual caveats regarding these.
Comment 16 my_linux 2008-01-16 03:29:28 EST
I will try to get the info for you tonight after doing a clean install just to 
be on the safe side. I will also post the grub and fstab straight after install.

Not sure if I have mentioned this before but I have tried both the Fedora 8 DVD 
and the Live CD install with the same results. I will be installing the x86_64 
Live CD.

The computer came with version 1.06 and is now on the latest 1.11 BIOS release. 
It has made no difference to the issue, there are also no controls for SATA / 
PATA / IDE function.
Comment 17 Christopher Brown 2008-01-16 08:24:59 EST
You may wish to consider using updated spins from the fedora unity project:

http://spins.fedoraunity.org/spins
Comment 18 my_linux 2008-01-16 17:20:42 EST
Created attachment 291902 [details]
lspci
Comment 19 my_linux 2008-01-16 17:21:11 EST
Created attachment 291903 [details]
dmidecode
Comment 20 my_linux 2008-01-16 17:21:33 EST
Created attachment 291904 [details]
dmesg
Comment 21 my_linux 2008-01-16 17:24:11 EST
The above were taken by booting from a GNOME Live USB stick created on another
computer running Fedora 8 using livecd script.

I will try from a clean install as soon as I have more time. If the above is OK
do let me know...
Comment 22 Christopher Brown 2008-01-16 18:00:45 EST
Notes from dmesg:

Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 0
Clockevents: could not switch to one-shot mode: lapic is not functional.
Could not switch to high resolution mode on CPU 1

Have you tried adding nolapic or noapic to the kernel boot parameters?
Comment 23 my_linux 2008-01-17 00:58:44 EST
Yes I have as far as I remember, I went through the Kernel CommonProblems:

http://fedoraproject.org/wiki/KernelCommonProblems

I will try it again tonight as I will much more time. Do you want me to post the
above again or anything else?
Comment 24 Christopher Brown 2008-01-17 09:21:32 EST
From the comments in dmesg it would appear the kernel is trying to enable lapic.
If you could try booting with nolapic and post the dmesg from that it would be good.
Comment 25 my_linux 2008-01-17 15:01:31 EST
I have no done a clean install of Fedora 8 x86_64 and only added nolapic to boot
parameters in Anaconda.

Straight after install was completed the computer was shutdown properly and then
booted up. First boot attempt failed with above error > forced shutdown >
restart, went to grub edited out rhgb quiet, tried again > booted.

I am attaching dmesg.txt after the installed boot up. If you need the other
files as above let me know.
Comment 26 my_linux 2008-01-17 15:09:33 EST
Created attachment 292058 [details]
dmesg

dmesg after install and nolapic setting
Comment 27 Chuck Ebbert 2008-01-17 16:56:12 EST
(In reply to comment #22)
> Notes from dmesg:
> 
> Clockevents: could not switch to one-shot mode: lapic is not functional.
> Could not switch to high resolution mode on CPU 0
> Clockevents: could not switch to one-shot mode: lapic is not functional.
> Could not switch to high resolution mode on CPU 1
> 
> Have you tried adding nolapic or noapic to the kernel boot parameters?

That's not necessary, the broken lapic is being autodetected and disabled.
Comment 28 Chuck Ebbert 2008-01-17 16:57:46 EST
(In reply to comment #20)
> Created an attachment (id=291904) [edit]
> dmesg
> 

It didn't find a hard drive on the first AHCI port here (booted from the live
USB key.)

ata3: SATA max UDMA/133 cmd 0xffffc20000ac8100 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata4: SATA max UDMA/133 cmd 0xffffc20000ac8180 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata5: SATA max UDMA/133 cmd 0xffffc20000ac8200 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata6: SATA max UDMA/133 cmd 0xffffc20000ac8280 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata3: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata4: SATA link down (SStatus 0 SControl 300)
ata5: SATA link down (SStatus 0 SControl 300)
ata6: SATA link down (SStatus 0 SControl 300)
Comment 29 Chuck Ebbert 2008-01-17 16:59:22 EST
(In reply to comment #26)
> Created an attachment (id=292058) [edit]
> dmesg
> 
> dmesg after install and nolapic setting

But here it does find the drive. Maybe the cable is loose or something?

ata1: SATA max UDMA/133 cmd 0xffffc20000ac0100 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata2: SATA max UDMA/133 cmd 0xffffc20000ac0180 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata3: SATA max UDMA/133 cmd 0xffffc20000ac0200 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata4: SATA max UDMA/133 cmd 0xffffc20000ac0280 ctl 0x0000000000000000 bmdma
0x0000000000000000 irq 2301
ata1: SATA link up 1.5 Gbps (SStatus 113 SControl 300)
ata1.00: ATA-7: Hitachi HTS541680J9SA00, SB2OC70P, max UDMA/100
ata1.00: 156301488 sectors, multi 16: LBA48 NCQ (depth 0/32)
ata1.00: configured for UDMA/100
ata2: SATA link down (SStatus 0 SControl 300)
ata3: SATA link down (SStatus 0 SControl 300)
ata4: SATA link down (SStatus 0 SControl 300)
Comment 30 my_linux 2008-01-17 17:36:43 EST
There is space for two hard drives in this computer, only one is installed.

Sometimes when booting from USB stick the hard disk is not detected. I have
noticed this in GParted and Anaconda, simply rebooting or shutting down then
rebooting fixes this. Possibly part of the problem?

I think the crash occurs when loading a storage related driver. It's very hard
to take a picture of the computer screen but I shall try or write down the
message and pass on.
Comment 31 my_linux 2008-01-17 17:49:01 EST
I don't think it's a cable / connector issue as Vista works fine and other
distros as above too work fine. May be something to do with storage drivers?
Comment 32 my_linux 2008-01-17 17:51:07 EST
or forgot to mention the order in which drivers load?
Comment 33 my_linux 2008-01-23 03:29:03 EST
I have reinstalled and applied all the updates. At the moment the computer is 
booting each time with kernel ending 85.

Hopefully this will be the end of this problem...

Note You need to log in before you can comment on or make changes to this bug.