Bug 308961 - LTC30281-rsh does not work if IP address can not be resolved to hostname
Summary: LTC30281-rsh does not work if IP address can not be resolved to hostname
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: rsh   
(Show other bugs)
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Adam Tkac
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On: 222624
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-27 13:30 UTC by Adam Tkac
Modified: 2013-04-30 23:37 UTC (History)
5 users (show)

Fixed In Version: rsh-0.17-59.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-01-22 09:14:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Comment 1 Adam Tkac 2007-09-27 13:33:29 UTC
Option -D will be removed in RHEL-6 because -a is sufficient. This change
requires release notes

Adam

Comment 2 Don Domingo 2007-09-28 02:39:56 UTC
hi Adam, 

please advise if i got the following release note correctly (for RHEL5.1 release
notes updates):

<quote>
rsh cannot function properly if IP addresses cannot be resolved to hostnames.
You need to use the -a option when running rsh in such an environment.
</quote>

Comment 3 Adam Tkac 2007-09-28 11:31:35 UTC
This change won't be in RHEL5. This is bug for RHEL6 because I will drop -D
option in RHEL6. So no release note is needed for RHEL5.1

Comment 4 RHEL Product and Program Management 2009-09-11 15:56:29 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 5 Adam Tkac 2010-01-22 09:14:10 UTC
In the end, due compatibility reasons, rshd accepts -D parameter but it has no effect. This bug can be considered as fixed.


Note You need to log in before you can comment on or make changes to this bug.