Bug 30933 - iwconfig causes load of appletalk and ipx modules
iwconfig causes load of appletalk and ipx modules
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: wireless-tools (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 02:20 EST by James Manning
Modified: 2014-03-16 22:19 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-07 22:31:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Manning 2001-03-07 02:20:05 EST
actually 2.4.2-0.1.16 kernel, but RC2 wireless-tools (20-4)

Mar  7 02:10:27 bp6 kernel: NET4: Linux IPX 0.44 for NET4.0 
Mar  7 02:10:27 bp6 kernel: IPX Portions Copyright (c) 1995 Caldera, Inc. 
Mar  7 02:10:27 bp6 kernel: IPX Portions Copyright (c) 2000 Conectiva, Inc. 
Mar  7 02:10:27 bp6 kernel: NET4: AppleTalk 0.18a for Linux NET4.0 


iwconfig (no params) causes appletalk and ipx modules to load.
eth0 and eth1 are "normal" ethernet, eth2 is wvlan_cs

if this should get filed under kernel, please refile for me :)

I'm not sure this is a "bug" per se, but wanted to make sure
it was known behavior.
Comment 1 Bill Nottingham 2001-03-07 22:30:58 EST
It's known that it does this; dunno if it's techinically a bug or not.
I may poke at it and see if it's something that can be changed.

You can always alias those modules (net-pf-3, net-pf-4) to 'off' if you
like.
Comment 2 Preston Brown 2001-03-23 16:43:25 EST
not a bug.  iwconfig loads them because they may be needed by a subsequent 
ifconfig.  They will get unloaded automatically if they aren't being used.

Note You need to log in before you can comment on or make changes to this bug.