Bug 309401 - Enable Desktop Effects causes window decorations to disappear, can't manage windows at all
Enable Desktop Effects causes window decorations to disappear, can't manage w...
Product: Fedora
Classification: Fedora
Component: compiz (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Kristian Høgsberg
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-09-27 13:34 EDT by Charles R. Anderson
Modified: 2011-04-18 02:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2009-07-14 14:07:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
evolution - hidden border - top-left (787.04 KB, image/png)
2007-10-11 10:04 EDT, shrek-m
no flags Details
glxinfo showing GLX_EXT_texture_from_pixmap (4.85 KB, text/plain)
2007-10-12 19:14 EDT, Charles R. Anderson
no flags Details
X configuration file (1.34 KB, text/plain)
2009-02-09 13:55 EST, Phillip Rhodes
no flags Details

  None (edit)
Description Charles R. Anderson 2007-09-27 13:34:42 EDT
Description of problem:

Using the Desktop Effects program, I can Enable Desktop Effects and see all the
pretty eye candy, but now the windows cannot be managed.  All the window borders
and decorations disappear, so I cannot move/resize/minimize windows at all.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. System->Preferences->Look and Feel->Desktop Effects
2. Enable Desktop Effects
Actual results:
Window borders and decorations are lost.

Expected results:
Full window manager functionality should remain.
Comment 1 shrek-m 2007-10-11 10:04:33 EDT
Created attachment 224321 [details]
evolution - hidden border - top-left
Comment 2 shrek-m 2007-10-11 10:05:57 EDT

now i can move the window once again with [alt]+[mouse]

if i open some applications eg. thunderbird, firefox, evolution, ...
the top-border is hidden under the  top-gnome-panel

sometimes firefox does remeber his last position on the desktop iand s not
hidden in the top-left corner.

00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
xorg-driver "i810"  because "intel" does not work at the moment.
Comment 3 shrek-m 2007-10-11 17:30:04 EDT

the top-panel is now visible for a short time while the logon then it disappers
until i click on the desktop. the problem is still the same with new windows

without "desktop effects" the top-panel is ok.
Comment 4 Charles R. Anderson 2007-10-12 18:41:24 EDT
Comments #1 #2 and #3 dont' reflect my current experience and the description of
this bug.  I get no window borders or title bars at all--it isn't that they are
hidden under the panel.  It acts as if no window manager is running at all.  All
my existing windows lose their decorations.  The decorations come back when I
turn off Desktop Effects.

I've since updated to compiz-0.6.0-1.fc8, and the same problem remains.  I'm
using the radeon driver on ATI FireGL Mobility T2.  I looked into this further
and if I run "compiz --replace" from a terminal I get these errors:

>compiz --replace
compiz (core) - Fatal: GLX_EXT_texture_from_pixmap is missing
compiz (core) - Error: Failed to manage screen: 0
compiz (core) - Fatal: No manageable screens found on display :0.0

compiz (cube) - Warn: Failed to load slide: /usr/share/pixmaps/fedora-logo
Comment 5 Charles R. Anderson 2007-10-12 19:14:57 EDT
Created attachment 226201 [details]
glxinfo showing GLX_EXT_texture_from_pixmap

The GLX_EXT_texture_from_pixmap error doesn't make sense.  Here is my glxinfo
showing that I do have GLX_EXT_texture_from_pixmap available as both a server
and client glx extension.

Is this maybe a Mesa or radeon driver bug?
Comment 6 shrek-m 2007-10-14 14:14:08 EDT
what happens when you unset your active_plugins with `gconftool-2` or
`gconf-editor` ?

$ gconftool-2 --unset /apps/compiz/general/allscreens/options/active_plugins

$ gconftool-2 -g /apps/compiz/general/allscreens/options/active_plugins

Comment 7 Dominik 'Rathann' Mierzejewski 2007-10-25 09:02:31 EDT
(In reply to comment #6)
> what happens when you unset your active_plugins with `gconftool-2` or
> `gconf-editor` ?
> $ gconftool-2 --unset /apps/compiz/general/allscreens/options/active_plugins
> $ gconftool-2 -g /apps/compiz/general/allscreens/options/active_plugins

I had the same problem with compiz-0.6.2-2.fc8, but the above fixes it. Thanks.
Comment 8 Charles R. Anderson 2007-10-26 19:19:30 EDT
On a new user account, compiz is working fine now.

On my existing user account, I had to unset active_plugins per Comment #6, and
it is now working too.

Are gconf settings not upgraded/migrated automatically?  Seems like a bad idea
since we support upgrading Fedora from one release to another.
Comment 9 Bug Zapper 2008-05-13 23:17:26 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
Comment 10 Rolf Fokkens 2008-06-23 08:08:05 EDT
For me removing the ~/.gconf directory solved the problem. There may be some old
data in there that causes the problem.
Comment 11 Phillip Rhodes 2009-02-09 13:55:03 EST
Created attachment 331345 [details]
X configuration file
Comment 12 Phillip Rhodes 2009-02-09 13:56:14 EST
FWIW, I see this behavior with Fedora 10, using compiz:


Strangely enough, it hasn't always happened.  Everything was working fine
with desktop effects enabled, until a few days ago.  Not sure if a recent
update broke this of what, but it's consistent now: desktop effects enabled =
no window decoration.

Attaching my xorg.conf file in case it may be helpful.   See 

Comment 13 shrek-m 2009-02-09 17:01:10 EST
happened here too, but i was playing with a new videocard and ccsm.

iirc this steps solved it:
1; disable desktop effects
2; logout, login  (or reboot)
3; unset  "apps/compiz/general/allscreens/options/active_plugins"
with `gconf-editor` or `gconftool-2`
4; enable desktop effects
5; check the settings for desktop effects and/or ccsm

$ gconftool-2 -g /apps/compiz/general/allscreens/options/active_plugins
Comment 14 Phillip Rhodes 2009-02-10 13:41:40 EST
Trying that didn't alleviate the problem for me.  

[prhodes@voyager ~]$ gconftool-2 -g /apps/compiz/general/allscreens/options/active_plugins


And I still lose the window decoration if I enable desktop effects.
Comment 15 Phillip Rhodes 2009-02-10 13:43:24 EST
Also, starting X as a new user, which some people have reported as a workaround for this problem - didn't help either, FWIW.
Comment 16 Phillip Rhodes 2009-02-13 11:05:25 EST
FWIW, today's batch of updates brought in a new compiz:


But the same problem still exists.
Comment 17 Bug Zapper 2009-06-09 18:52:58 EDT
This message is a reminder that Fedora 9 is nearing its end of life.
Approximately 30 (thirty) days from now Fedora will stop maintaining
and issuing updates for Fedora 9.  It is Fedora's policy to close all
bug reports from releases that are no longer maintained.  At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '9'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 9's end of life.

Bug Reporter: Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 9 is end of life.  If you 
would still like to see this bug fixed and are able to reproduce it 
against a later version of Fedora please change the 'version' of this 
bug to the applicable version.  If you are unable to change the version, 
please add a comment here and someone will do it for you.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events.  Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

The process we are following is described here: 
Comment 18 Bug Zapper 2009-07-14 14:07:02 EDT
Fedora 9 changed to end-of-life (EOL) status on 2009-07-10. Fedora 9 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.
Comment 19 Anand Nande 2011-04-18 01:48:59 EDT
comments 6,13,14 were very helpful to fix my issue..thanks

Note You need to log in before you can comment on or make changes to this bug.