Bug 309581 - grass-support macro fails to disable grass support
grass-support macro fails to disable grass support
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: gdal (Show other bugs)
9
All Linux
low Severity low
: ---
: ---
Assigned To: Balint Cristian
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 14:36 EDT by Matt Whiteley
Modified: 2008-05-26 12:07 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-26 12:07:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt Whiteley 2007-09-27 14:36:26 EDT
Description of problem:
The _with_grass macro in the srpm doesn't have the desired effect. The logic in
the grass_support macro is failing to disable grass_support when _with_grass is
set to 0

Version-Release number of selected component (if applicable):
1.4.2-3.fc8

How reproducible:
Always


Steps to Reproduce:
1.rpmbuild --define '_with_grass 0' gdal.spec
(I also tried setting it in the file and not using the define on the command line)
  
Actual results:
Fails to build gdal since grass-devel isn't installed


Expected results:
Grass support disabled and build succeeds

Additional info:
I would like to know what the suggested method of building both grass and gdal
is. Are these the proper steps?
-build gdal without grass support
-install gdal without grass support
-build grass
-install grass
-build gdal with grass support
-upgrade gdal to version with grass support
Comment 1 Bug Zapper 2008-05-13 23:17:32 EDT
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping
Comment 2 Balint Cristian 2008-05-26 11:18:59 EDT
> I would like to know what the suggested method of building both grass and gdal
> is. Are these the proper steps?
> -build gdal without grass support
> -install gdal without grass support
> -build grass
> -install grass
> -build gdal with grass support
> -upgrade gdal to version with grass support

Yes. True.
Comment 3 Balint Cristian 2008-05-26 12:07:41 EDT
removed this option, and hardcoded. however relese cycle is long enugh upstream.

Note You need to log in before you can comment on or make changes to this bug.