Bug 309911 - can't "yum update" due to pirut/yum dependency problem
can't "yum update" due to pirut/yum dependency problem
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 15:57 EDT by Christopher Beland
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 10:13:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Christopher Beland 2007-09-27 15:57:15 EDT
When I run "yum update" I get:

Resolving Dependencies
--> Running transaction check
---> Package kernel.i686 0:2.6.22.7-85.fc7 set to be updated
---> Package pirut.noarch 0:1.3.20-1.fc7 set to be updated
--> Processing Dependency: python-iniparse for package: pirut
--> Processing Dependency: yum >= 3.2.5-2 for package: pirut
---> Package fuse-libs.i386 0:2.7.0-5.fc7 set to be updated
---> Package kernel-headers.i386 0:2.6.22.7-85.fc7 set to be updated
---> Package info.i386 0:4.11-1.fc7 set to be updated
---> Package fuse.i386 0:2.7.0-5.fc7 set to be updated
---> Package libselinux.i386 0:2.0.14-8.fc7 set to be updated
---> Package libselinux-python.i386 0:2.0.14-8.fc7 set to be updated
--> Running transaction check
---> Package pirut.noarch 0:1.3.20-1.fc7 set to be updated
--> Processing Dependency: yum >= 3.2.5-2 for package: pirut
---> Package python-iniparse.noarch 0:0.2.2-1.fc7 set to be updated
--> Finished Dependency Resolution
Error: Missing Dependency: yum >= 3.2.5-2 is needed by package pirut

I have the updates-testing and updates-testing-debuginfo repositories enabled,
in addition to the standard ones.
Comment 1 Neil Horman 2007-09-27 19:02:15 EDT
As part of bz 269761 I'm testing an update to kdump that will allow and aribrary
script to be run prior to starting the capture of the vmcore.  This should allow
one to fork an app that sends a periodic heartbeat to the cluster fence daemon.
 If such a heartbeat monitor can be added to the cluster suite, and a slim
application to drive such a heartbeat, we should be able to prevent the fencing
from happening.   Thoughts?
Comment 2 Jeremy Katz 2007-09-28 10:13:09 EDT
Yeah, I've requested an unpush of the pirut update from -updates-testing until
we get the new yum out.  I had a brain misfire and thought 3.2.5-2 had been
pushed there.
Comment 3 Christopher Beland 2007-10-01 15:35:51 EDT
The unpush seems to have gone through, so updates are working again.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.