Bug 310031 - anthy optional when it isn't
anthy optional when it isn't
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: comps (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 17:35 EDT by Warren Togami
Modified: 2014-01-21 17:59 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-27 20:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Warren Togami 2007-09-27 17:35:38 EDT
comps-f8.xml.in contains:

<packagereq type="conditional"
requires="xorg-x11-server-Xorg">scim-anthy</packagereq>
<packagereq type="conditional"
requires="xorg-x11-server-Xorg">scim-lang-japanese</packagereq>
<packagereq type="optional">anthy</packagereq>

This means anthy is given as an "optional" package during Anaconda, however it
shouldn't be because it is pulled in by the mandatory scim-anthy package if the
user selects Japanese.

Just confirming with Jens, we should remove this anthy line right?
Comment 1 Warren Togami 2007-09-27 17:38:28 EDT
Additionally, you may want to check all of your languages to see if other
packages are similar to this in comps.
Comment 2 Jens Petersen 2007-09-27 20:08:37 EDT
Well anthy can also be used outside X even as a library say from Emacs
or other clients, so it doesn't hurt to have it there as optional.
Comment 3 Jens Petersen 2007-09-27 20:13:38 EDT
(In reply to comment #1)
> Additionally, you may want to check all of your languages to see if other
> packages are similar to this in comps.

I can't think of any other cases - but I can recheck the various lang groups.
Comment 4 Jens Petersen 2007-09-27 20:32:25 EDT
Tagoh suggested replacing anthy with "anthy-el" and "uim-anthy".
With those and scim-anthy that basically covers all the users of anthy
and so yes we should remove the library from comps. :)

Thanks, Warren, for catching this.

Should be fixed now in comps-f8.

Note You need to log in before you can comment on or make changes to this bug.