Bug 31011 - broadcom gigabit nic driver (bcm5700.o) rmmod issue... possibly hotplug related like 3c90x was?
broadcom gigabit nic driver (bcm5700.o) rmmod issue... possibly hotplug rela...
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: hotplug (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 16:24 EST by Jonathan Arehart
Modified: 2007-04-18 12:32 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 14:21:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Arehart 2001-03-07 16:24:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2 i686)


After "rmmod bcm5700" and "lsmod" shows the module still loaded.

Reproducible: Always
Steps to Reproduce:
1.  Boot system with Florence RC2
2.  Insmod bcm5700
3.  Rmmod bcm5700 and then do an lsmod.  bcm5700 is back after the rmmod
(when done by hand).  See below for more.

Actual Results:
[root@localhost /root]# lsmod > out.txt; echo >> out.txt; rmmod appletalk;
  rmmod ipx; lsmod >> out.txt; echo >> out.txt; rmmod bcm5700; lsmod >>
  out.txt; echo >> out.txt; sleep 2; lsmod >> out.txt

# before anything
Module                  Size  Used by
bcm5700                29792   0  (autoclean) (unused)
appletalk              20176   0  (autoclean)
ipx                    15264   0  (autoclean)
autofs                 11264   1  (autoclean)
e100                   44176   1  (autoclean)
ipchains               38816   0  (unused)
usb-ohci               16992   0  (unused)
usbcore                49456   1  [usb-ohci]
megaraid               22384   8
aic7xxx               136272   0  (unused)
sd_mod                 11680   8
scsi_mod               94912   3  [megaraid aic7xxx sd_mod]

# ipx and appletalk out
Module                  Size  Used by
bcm5700                29792   0  (autoclean) (unused)
autofs                 11264   1  (autoclean)
e100                   44176   1  (autoclean)
ipchains               38816   0  (unused)
usb-ohci               16992   0  (unused)
usbcore                49456   1  [usb-ohci]
megaraid               22384   8
aic7xxx               136272   0  (unused)
sd_mod                 11680   8
scsi_mod               94912   3  [megaraid aic7xxx sd_mod]

# bcm5700 out
Module                  Size  Used by
autofs                 11264   1  (autoclean)
e100                   44176   1  (autoclean)
ipchains               38816   0  (unused)   
usb-ohci               16992   0  (unused)   
usbcore                49456   1  [usb-ohci] 
megaraid               22384   8 
aic7xxx               136272   0  (unused)
sd_mod                 11680   8 
scsi_mod               94912   3  [megaraid aic7xxx sd_mod]

# 2 seconds later; bcm5700 back
Module                  Size  Used by
bcm5700                29792   0  (autoclean) (unused)
appletalk              20176   0  (autoclean)
ipx                    15264   0  (autoclean)
autofs                 11264   1  (autoclean)
e100                   44176   1  (autoclean)
ipchains               38816   0  (unused)   
usb-ohci               16992   0  (unused)   
usbcore                49456   1  [usb-ohci] 
megaraid               22384   8 
aic7xxx               136272   0  (unused)
sd_mod                 11680   8 
scsi_mod               94912   3  [megaraid aic7xxx sd_mod]

I scripted this to see what the timing was like, and to show that the
module does successfully rmmod, but returns shortly after.

Expected Results:  The module should have unloaded and stayed unloaded
unless I did "ifup eth1" or "insmod bcm5700".

This is in a 2U server machine where both NICs (the Intel eepro100/e100 and
the Broadcom bm5700) are on the motherboard.  Possibly hotplug related?

One more note, my Bugzilla account isn't yet a member of the beta team (as
far as I can tell), so I'm unable to post this bug there (and therefore
directly under the RC2 category).
Comment 1 Bill Nottingham 2001-03-07 16:43:42 EST
Do you have the latest hotplug installed (2001_02_14-12)
Comment 2 Jonathan Arehart 2001-03-07 20:44:20 EST
No, at the moment hotplug-2001_02_14-9 is installed.  Will install 2001_02_14-12
and try again.
Comment 3 Trond Eivind Glomsrxd 2001-03-07 23:47:01 EST
I'm guessing this is a duplicate of the eepro one... I've set up a machine with
this, and I'll check with the current trees.
Comment 4 Jonathan Arehart 2001-03-08 14:07:30 EST
Upgrading hotplug to 2001_02_14-12 allows me to correctly rmmod bcm5700.  Any
ideas why it always loads appletalk and ipx?
Comment 5 Bill Nottingham 2001-03-08 14:21:20 EST
hotplug runs iwconfig on the card to see if it needs wireless initialization
stuff; this causes appletalk & ipx to get loaded

Note You need to log in before you can comment on or make changes to this bug.