Bug 31012 - xchat crashes when selecting Settings->Palette
xchat crashes when selecting Settings->Palette
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: xchat (Show other bugs)
7.1
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
:
: 36668 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-07 16:52 EST by Need Real Name
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-12-07 17:24:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Red Hat Bugzilla 2001-03-07 16:52:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


The version of xchat that came with Wolverine (xchat-1.6.3-3) crashes when
selecting Settings->Palette.

Stack trace:
#0  0x4055afb9 in __wait4 () from /lib/libc.so.6
#1  0x405c8d0c in __DTOR_END__ () from /lib/libc.so.6
#2  0x400a7213 in waitpid (pid=1662, stat_loc=0xbfffec08, options=0)
    at wrapsyscall.c:172
#3  0x401237b8 in gnome_segv_handle () from /usr/lib/libgnomeui.so.32
#4  0x400a55f5 in pthread_sighandler (signo=11, ctx=
      {gs = 7, __gsh = 0, fs = 0, __fsh = 0, es = 43, __esh = 0, ds = 43,
__dsh = 32, edi = 0, esi = 136827480, ebp = 3221221424, esp = 3221221288,
ebx = 136746384, edx = 136032312, ecx = 0, eax = 0, trapno = 14, err = 4,
eip = 134724629, cs = 35, __csh = 0, eflags = 2163270, esp_at_signal =
3221221288, ss = 43, __ssh = 0, fpstate = 0xbfffed28, oldmask = 2147483648,
cr2 = 448}) at signals.c:97
#5  <signal handler called>
#6  0x0807bc15 in palette_edit () at eval.c:41
#7  0x40270361 in gtk_marshal_NONE__NONE () from /usr/lib/libgtk-1.2.so.0
#8  0x402a2a86 in gtk_handlers_run () from /usr/lib/libgtk-1.2.so.0
#9  0x402a1dbd in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#10 0x4029fb75 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#11 0x402d9f10 in gtk_widget_activate () from /usr/lib/libgtk-1.2.so.0
#12 0x40278639 in gtk_menu_shell_activate_item () from
/usr/lib/libgtk-1.2.so.0
#13 0x402777b2 in gtk_menu_shell_button_release ()
   from /usr/lib/libgtk-1.2.so.0
#14 0x4027006c in gtk_marshal_BOOL__POINTER () from
/usr/lib/libgtk-1.2.so.0
#15 0x402a1dfd in gtk_signal_real_emit () from /usr/lib/libgtk-1.2.so.0
#16 0x4029fb75 in gtk_signal_emit () from /usr/lib/libgtk-1.2.so.0
#17 0x402d9dc9 in gtk_widget_event () from /usr/lib/libgtk-1.2.so.0
#18 0x4026ffe5 in gtk_propagate_event () from /usr/lib/libgtk-1.2.so.0
#19 0x4026f0bf in gtk_main_do_event () from /usr/lib/libgtk-1.2.so.0
#20 0x40324b7f in gdk_event_dispatch () from /usr/lib/libgdk-1.2.so.0
#21 0x400358f3 in g_main_dispatch () at eval.c:41
#22 0x40035f38 in g_main_iterate () at eval.c:41
#23 0x400360fc in g_main_run () at eval.c:41
#24 0x4026e983 in gtk_main () from /usr/lib/libgtk-1.2.so.0
#25 0x0809f99e in main () at eval.c:41
#26 0x404bf091 in __libc_start_main (main=0x809f970 <main>, argc=1, 
    ubp_av=0xbffff9bc, init=0x8067d44 <_init>, fini=0x816c66c <_fini>, 
    rtld_fini=0x4000e374 <_dl_fini>, stack_end=0xbffff9b4)
    at ../sysdeps/generic/libc-start.c:129



Reproducible: Always
Steps to Reproduce:
1. open xchat
2. select Settings->Palette
3. observe crash
Comment 1 Red Hat Bugzilla 2001-03-07 16:59:29 EST
tried it on a few machines... cannot find the bug
Comment 2 Red Hat Bugzilla 2001-05-02 16:58:36 EDT
I got caught by this bug. The solution was to "rename" my old .xchat config
directory out of the way and let xchat create a new one. Worked fine after that,
but I had to re-create my various settings.
Comment 3 Red Hat Bugzilla 2001-05-03 14:33:48 EDT
More info.

Even after having xchat recreate all the config files (which allows the program
to mostly work), going into "pallette" causes a hard crash.

Reproducible on my workstation at will.
Comment 4 Red Hat Bugzilla 2001-05-07 15:28:45 EDT
Even more info...

palette is not the only setting that can trigger this failure. Specifically, it
appears the problem is a setting in the xchat.conf file. Deleteing this file and
leeting xchat recreate it will always result in a working program.
Comment 5 Red Hat Bugzilla 2001-07-05 23:56:59 EDT
*** Bug 36668 has been marked as a duplicate of this bug. ***
Comment 6 Red Hat Bugzilla 2001-07-12 15:21:41 EDT
Sent mail upstream.
Comment 7 Red Hat Bugzilla 2001-07-16 18:47:25 EDT
Still happens with new 1.8.1 version.
Comment 8 Red Hat Bugzilla 2001-07-18 12:41:46 EDT
Ugh, I built XChat with debugging and this went away ;-)
Comment 9 Red Hat Bugzilla 2002-01-07 07:27:51 EST
I'm not able to reproduce this in xchat 1.8.6 which is currently
in rawhide, and will be released very soon for older releases, just
because I'm such a nice guy.  ;o)

I'm marking it ERRATA.  It should appear as errata within a
week.

Note You need to log in before you can comment on or make changes to this bug.