Bug 310181 - Networking dialog box greys out DHCP choice once static information is entered
Networking dialog box greys out DHCP choice once static information is entered
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: system-config-network (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-27 20:43 EDT by Andrew P. Lentvorski, Jr.
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-30 02:55:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of radio button selecting between DHCP and static (665.15 KB, image/png)
2007-10-02 05:36 EDT, Andrew P. Lentvorski, Jr.
no flags Details
where to click (49.72 KB, image/png)
2007-10-02 06:20 EDT, Harald Hoyer
no flags Details

  None (edit)
Description Andrew P. Lentvorski, Jr. 2007-09-27 20:43:44 EDT
Description of problem:
Networking dialog box greys out DHCP choice once static information is entered.

The only way to get the DHCP choice back is to actually delete all of the static
IP information and *only then* will you get the DHCP selection back.

This is severely non-informative and non-intuitive.  I tripped over this when a
beginner switched the choice and then couldn't figure out how to change it back.
 Even *I* had to go hit Google in order to figure out how to change it back.

At the very least, when the DHCP selection is greyed out, add some text to the
dialog stating how to ungrey it.  Even better, don't grey it out, but record the
static IP information in gconf so that even if the system gets switched to DHCP
for an address it can be switched back to static with no information loss.

This is likely caused by the fact that the current networking setup is solely
used to populate the dialog box rather than looking first at the current
configuration and then checking a gconf cache for the rest.
Comment 1 Dan Williams 2007-10-01 15:18:52 EDT
-> s-c-n, not NetworkManager
Comment 2 Harald Hoyer 2007-10-02 05:14:09 EDT
s-c-network? 
You have a simple radio button to make the choice between static and dynamic
adresses...
Maybe you mean anaconda :)
Comment 3 Andrew P. Lentvorski, Jr. 2007-10-02 05:36:55 EDT
Created attachment 213231 [details]
screenshot of radio button selecting between DHCP and static
Comment 4 Andrew P. Lentvorski, Jr. 2007-10-02 05:38:08 EDT
Well, it's not *my* fault you folks hide what command actually gets executed
when I click on things.  :)

So, have an attached screenshot.

Note the "Ethernet Device" window and the radio button choice for "Automatically
obtain IP Address" or "Statically set IP address".
Comment 5 Harald Hoyer 2007-10-02 06:20:58 EDT
Created attachment 213251 [details]
where to click
Comment 6 Harald Hoyer 2007-10-02 06:21:47 EDT
> The only way to get the DHCP choice back is to actually delete all of the static
> IP information and *only then* will you get the DHCP selection back.

This is not true... Why don't you click on the radio buttons, I marked in the
attachment?

Note You need to log in before you can comment on or make changes to this bug.