Bug 310331 - System hang on DELL server with ES1000 video chip
System hang on DELL server with ES1000 video chip
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.0
All Linux
high Severity high
: ---
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 01:35 EDT by LisaWu
Modified: 2013-06-21 14:42 EDT (History)
7 users (show)

See Also:
Fixed In Version: RHEA-2008-0474
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:31:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
add xf86PruneDriverModes after xf86ValidateModes. (1.29 KB, patch)
2007-09-28 01:35 EDT, LisaWu
no flags Details | Diff

  None (edit)
Description LisaWu 2007-09-28 01:35:16 EDT
Description of problem:

This issue is originally found by Dell when testing "SLES10-SP1" on their 
server with RN50 video chip.
When using sax2 (Suse tool to configure display) to change resolution to 
1280x1024, system hangs.

The root cause is:
Radeon driver forget to prune invalid modes after xf86ValidateModes. invalid 
modes are set to output and cause video chip hang.
Comment 1 LisaWu 2007-09-28 01:35:16 EDT
Created attachment 209521 [details]
add xf86PruneDriverModes after xf86ValidateModes.
Comment 2 Adam Jackson 2007-10-04 12:00:36 EDT
Looks good to me.
Comment 3 RHEL Product and Program Management 2007-10-15 23:37:17 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 John Poelstra 2008-04-02 17:37:24 EDT
Greetings Red Hat Partner,

A fix for this issue should be included in the latest packages contained in
RHEL5.2-Snapshot3--available now on partners.redhat.com.  

Please test and confirm that your issue is fixed.

After you (Red Hat Partner) have verified that this issue has been addressed,
please perform the following:
1) Change the *status* of this bug to VERIFIED.
2) Add *keyword* of PartnerVerified (leaving the existing keywords unmodified)

If this issue is not fixed, please add a comment describing the most recent
symptoms of the problem you are having and change the status of the bug to ASSIGNED.

If you are receiving this message in Issue Tracker, please reply with a message
to Issue Tracker about your results and I will update bugzilla for you.  If you
need assistance accessing ftp://partners.redhat.com, please contact your Partner
Manager.

Thank you
Comment 7 errata-xmlrpc 2008-05-21 13:31:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0474.html

Note You need to log in before you can comment on or make changes to this bug.