Bug 310371 - add widescreen resolution support for radeon driver
add widescreen resolution support for radeon driver
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xorg-x11-drv-ati (Show other bugs)
5.0
All Linux
low Severity medium
: ---
: ---
Assigned To: Dave Airlie
desktop-bugs@redhat.com
: OtherQA
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 02:39 EDT by LisaWu
Modified: 2013-06-21 14:44 EDT (History)
5 users (show)

See Also:
Fixed In Version: RHEA-2008-0474
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 13:31:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
set native resolution for widescreen digital panel (1.08 KB, patch)
2007-09-28 02:39 EDT, LisaWu
no flags Details | Diff

  None (edit)
Description LisaWu 2007-09-28 02:39:42 EDT
set native resolution for widescreen digital panel

Reproduce: 
1.connect a 1440x900 digital panel to system
2.startx
3.1280x1024 was set to output instead of native 1440x900 resolution
Comment 1 LisaWu 2007-09-28 02:39:42 EDT
Created attachment 209571 [details]
set native resolution for widescreen digital panel
Comment 2 Adam Jackson 2007-10-04 12:01:34 EDT
Not completely sure what the patch is doing on first glance, but this is
certainly something we should investigate.
Comment 3 LisaWu 2007-10-05 22:36:34 EDT
In function RADEONValidateDDCModes, virtualX and virtualY are calculated
seperately like this: maxVirtY = MAX(maxVirtY, p->VDisplay);maxVirtX =
MAX(maxVirtX, p->HDisplay);
This is OK in old days when widescreen resolution is not support, big
resolutions always have both bigger HDISPLAY and VDISPLAY than little
resolutions.
But widescreen resolution will in fact brake this old time algorithm because a
big widescreen resolution (say 1440x900) has a bigger HDISPLAY and a smaller
VDISPLAY than a small resolution(say 1280x1024). 

I suggest a better way to calculate virtualX and virtualY to deal with
widescreen resolutions:
    maxVirtX = MAX(maxVirtX, p->HDisplay);
    maxVirtY = (maxVirtX == p->HDisplay)? p->VDisplay: maxVirtY;
Comment 4 RHEL Product and Program Management 2007-10-15 23:37:13 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 6 Cameron Meadors 2008-04-28 15:25:46 EDT
Could the report please test?
Comment 8 errata-xmlrpc 2008-05-21 13:31:28 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2008-0474.html

Note You need to log in before you can comment on or make changes to this bug.