Bug 31053 - RedHat 6.2 CDROM Installer fails to install program
RedHat 6.2 CDROM Installer fails to install program
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.2
i586 Linux
high Severity high
: ---
: ---
Assigned To: Brent Fox
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 00:05 EST by frcswll
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 12:32:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description frcswll 2001-03-08 00:05:09 EST
The installer on the cdrom distribution simply does not work on my machine.  It usually crashes at the point where the hard drive has to be accessed.  
This access can be caused by disk druid or fdisk when the partitions and mount points are being set up during an installation.  It is also caused by disk 
access when updating my 6.0 version, specifically when the program starts looking for packages to update.  It is consistent and occurs whether in 
graphical or text modes.  The message given in text mode when the install crashes is that a "signal 11" was received and the system is shutting down. 
 
My system is configured as follows:

    Processor: AMD K-6/2 400
    Memory:     128M SDRAM
    MotherBoard: AOpen AX59Pro using VIA Chipset
    HardDrives: Western Digital 20G and Western Digital 30G
    CDROM:    AOpen 1252 cdrom read/writer
    
I have reviewed the bug reports similar to this one.  I have checked the other consoles and there is no unusual activity noted or any informative error 
messages.  I really think you have blown off most of the individuals who contacted you about this problem.  Your answers have basically consisted of 
asking for more information or telling the individual that they need to acquire version 7.0 because this fixes the problem.  This is not good customer 
service.  If you give me an answer similar to the ones listed in your database of bug reports Redhat 6.2 will be the last product I purchase which carries 
the RedHat logo!  I expect you to fix this installer problem in 6.2 or send me the 7.0 (or latest 7 version) installation disks at no charge.    

Let me repeat: This is not a hardware problem.  Redhat 6.0 and Windows 98SE both installed without a problem.  This is a problem with the installer 
code and I expect you to fix the problem "real soon now."

F. James Caswell
10351 East Wing Road
Shepherd, MI  48883

frcswll@gte.net
Comment 1 Michael Fulbright 2001-03-08 11:54:57 EST
Please give the steps required to reproduce this issue.

Also does this occur in both text and graphical mode?
Comment 2 frcswll 2001-03-09 23:30:24 EST
3/9/2001

This problem happens in both the text and graphic modes of the installation program.  Further, it seems to happen right after inputting the drive partitions 
and mount points in either disk druid or fdisk.  The indicator light on the cdrom comes on for a second, as if the program is trying to access the cdrom 
and failing to do so.  At this point the installation freezes.  If I am in the text mode all the other consoles can be accessed and the one with the bash 
prompt is functional.  If I am using the graphical installation I can access the other consoles but the bash prompt is also frozen.  Please note that all 
accesses and steps up to this point in the installation process appear to work properly.  The information displays on the other consoles do not indicate 
that there is anything wrong.  F. James Caswell
Comment 3 Michael Fulbright 2001-04-02 11:49:56 EDT
Assigning to an engineer.
Comment 4 Brent Fox 2001-04-02 16:49:24 EDT
When a system just crashes without any error messages or any other clues as to
what went wrong, it's almost impossible for us to debug, especially without
physical access to the machine. So when we recommend trying version 7.0 in
situations like these, it's not because we're blowing people off. 

Many improvements have been made to subsystems like RPM and the kernel that may
fix the problem you are having. Red Hat Linux 7.0 is available free of charge on
ftp.redhat.com (and countless other ftp sites). I understand bandwidth
constraints may make this hard, but it's there nontheless.

I would encourage you to try using the boot disk errata that we released for
6.2.  It can be found at http://www.redhat.com/support/errata/RHBA-2000-015.html.

Also, is the 6.0 system you are trying to upgrade running software RAID by any
chance?  I know that doing a complete reinstall isn't a very attractive option,
but there may be a bug with upgrading that may not occur if you back up your
data and do a fresh install.

I would really like to get this working for you, and I'm going to try, but I
hope you understand the difficulty in debugging the system when there are no
meaningful error messages.
Comment 5 frcswll 2001-04-07 11:28:35 EDT
April 7, 2001

Response to your April 2, 2001, reply.

1) My 6.0 installation did not include RAID.  I do not have any RAID devices and
did not activate this feature.

2) Before contacting RedHat I downloaded the installation errata using another
operating system.  The errata installation disks exhibited the same symptoms as
the cd installation.

New Information.

Being a determined type of individual, but not a programmer, I reformated the
linux partitions using PartitionMagic 5.0.  I then did a complete installation
of my 6.0 system.  Prior to executing the disk partition and mount point
installation I switched to terminal 2 (bash prompt).  Once at the prompt I
searched the directory tree looking for my physical hard drives.  I found all
the hard drives and the various partitions I was going to use for this
installation under the /mnt directory.  I then allowed the installation to
proceed which it did flawlessly.

I followed the same procedure with a clean installation of 6.2.  Reformated the
partitions with PartitionMagic 5.0; started the installation; and switched to
terminal 2 (bash prompt) just prior to executing the command to establish the
mount points for the various partitions I wanted to use.  Again I searched the
directory tree for my physical harddrives and partitions.  These could not be
found.  I suspect the installation code fails to mount the physical devices. 
This is the point where the 6.2 installation crashes, failing to write any error
messages.  Even if it did send error messages in the other terminals to the
consoles these would not be accessible because it crashes with a signal 11 which
shuts down the entire system.

As of today I have solved the problem with a work around.  I did a little
reading after installing 6.0 so I could access the disk version of a publication
dealing with the RPM.  Here I found a reference to the -F (freshen) parameter. 
Using this parameter I could update the 6.0 installation to 6.2 manually from
the command line.  It actually worked quite well once I figured out that the
first step was to use the -u and -t options to find out which packages from 6.2
would have to be installed to allow the -F to work properly on all remaining
files.  Currently I have the 6.2 system up and running.

Editoral Comment
Being told to use a 56K dialup connection (usually operating at 48K) to download
540 meg of data to fix a problem is very similar to the Microsoft approach; buy
our next version which fixes your problems.  This may be appropriate if the
problem is one of lack of features which the customer desires to use.  It is not
appropriate where the operating system installation routines are failing. 
Another viable option is to  secure enough information from the customer to
determine what it is the customer really wants.  I my case what I really wanted
was a relatively efficient method to install the 6.2 operating system.  If a
simple work around is available you can then recommend it.

F. James Caswell
Comment 6 Brent Fox 2001-04-11 12:32:02 EDT
So, did you upgrade the kernel RPM too?  I'm curious because it looks like the
kernel that shipped with 6.2 doesn't work too well with your machine (hence the
Signal 11 during the 6.2 installation process).  Red Hat Linux actually ships
with a few different kernels...one for single processor machines, one for dual
processor machines, a boot kernel, and some others.  The 'boot' kernel is a
stripped down version of the kernel that the installer uses to get itself up and
going.  Since it is so stripped down, it is not unheard of for the boot kernel
to behave differently from the full standard kernel used during regular
operation of the system.

My guess is that something changed with the kernel between 6.0 and 6.2 that
caused this problem.  Hopefully this has been fixed in the newer kernels, but
it's hard to tell without being able to run a debug utility on the system in
question to figure out what the kernel was doing when it crashed.

It looks like you have found a suitable workaround, but it is unfortunate that
the upgrade did not work correctly in the installer.  Upgrading from 6.0 to 6.2
was tested by our QA deptartment and it works on our test machines here, so it's
hard to say exactly where the problem lies.  Thanks for your report.
Comment 7 frcswll 2001-04-29 19:35:54 EDT
April 29, 2001

Sorry about the delay in replying to your email of 4/16/2001.  We were on
vacation in the Southwest and just got home.

In response to your email; yes, I did upgrade the kernel to 6.2 using the
procedure previously described.  So far I have not noted any problems with the
kernel.  The version I am using is 2.2.14-5.0 for the i586 chips.  I am using
the single processor version of this kernel, not the smp version.  I plan on
upgrading the kernal to the current version sometime in the near future (current
for RedHat 6.2).

One thing bothers me about this whole situation.  When I first purchased RedHat
6.2 the installation routines worked fine.  That is how I orginally got the
operating system installed.  At that time I had different harddrives, a
different sound card, and a different CD-ROM.  The harddrives were a 3 GB Maxtor
Diamond Max set as master and an 8.5 GB Western Digital Caviar (28400) set as
the slave.  The sound card was a SoundBlaster 16.   The CD-ROM was a 40X Acer
CD-Rom.  I wonder if the change in hardware, especially the harddrives, caused
this problem.

Note You need to log in before you can comment on or make changes to this bug.