Bug 31058 - lpd no longer works, many problems
lpd no longer works, many problems
Status: CLOSED DUPLICATE of bug 31057
Product: Red Hat Linux
Classification: Retired
Component: LPRng (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Crutcher Dunnavant
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 05:46 EST by Levente Farkas
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-08 05:47:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Levente Farkas 2001-03-08 05:46:56 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.14 i686)


the old printcap file do not converted to the new format, and the even
if I change it by hand it's no longer works (see results). I even try to
use the new printtool (which is far worse then the old one, at least I cant
find old options eg. on out HP lj5M I use 2 pages per output pages which
simple disappear, sad:-((). after I reconfigure the printers those still
not work.
when I restart lpd I always get:
-------------------------
Stopping lpd:                                              [  OK  ]
Starting lpd: Warning - 'if' filter '/var/spool/lpd/hp5m/filter' does not
have execute perms
Warning - 'if' filter '/var/spool/lpd/canon/filter' does not have execute
perms
                                                           [  OK  ]
-------------------------
but when I change the permission from 600 to 700 and restart again:
-------------------------
Stopping lpd:                                              [  OK  ]
Starting lpd: Warning - permissions of 'filter' are 0700, not 0600
Warning - 'if' filter '/var/spool/lpd/hp5m/filter' does not have execute
perms
Warning - 'if' filter '/var/spool/lpd/canon/filter' does not have execute
perms
                                                           [  OK  ]
-------------------------

Reproducible: Always
Steps to Reproduce:
1. upgarde from 7.0
2. try to print
3. restart lpd
	

Actual Results:  I see such logs:
-------------------
Printer: hp5m@garfield (dest hp5m@hp5m.inside)
 Queue: no printable jobs in queue
 Status: subserver pid 1213 exit status 'JFAIL' at 10:28:39.950
 Filter_status: sending to hp5m.inside
Printer 'hp5m@hp5m.inside' - cannot open connection - Connection refused
------------------
there is no user required for printing, so I don't know from where lpd find
out the hp5m user ???
------------------
Status: IF filter 'mf_wrapper' filter msg - 'closing *main::KID3' at
19:35:44.289
Status: IF filter 'filter' filter msg - 'Make_passthrough: pid 1214, execve
'/var/spool/lpd/hp5m/filter' failed - 'Permission denied'' at 10:27:52.959
 Status: IF filter 'filter' filter exit status 'JABORT' at 10:27:52.959
------------------
....

Expected Results:  I able to print:-)
Comment 1 Bill Nottingham 2001-03-08 11:20:01 EST

*** This bug has been marked as a duplicate of 31057 ***

Note You need to log in before you can comment on or make changes to this bug.