Bug 31073 - Kickstart raiding / makes lilo fail
Summary: Kickstart raiding / makes lilo fail
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-08 16:38 UTC by Anders Blomdell
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-07-16 16:23:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Anders Blomdell 2001-03-08 16:38:35 UTC
With this in the kickstart file:

  clearpart --all
  part raid.01 --size 2000 --ondisk hda
  part raid.02 --size 2000 --ondisk hdb
  part swap --size 1000 --ondisk hda
  part swap --size 1000 --ondisk hdb
  part /backup/homeB --size 20000 --ondisk hda
  part /backup/homec --size 20000 --ondisk hdb
  raid / --level 1 --device md0 raid.01 raid.02 

Gives this partitioning:

  Disk /tmp/hda: 255 heads, 63 sectors, 5606 cylinders
  Units = cylinders of 16065 * 512 bytes

     Device Boot    Start       End    Blocks   Id  System
  /tmp/hda1   *         1      2550  20482843+  83  Linux
  /tmp/hda2          2551      5606  24547320    5  Extended
  /tmp/hda5          2551      2805   2048256   fd  Linux raid autodetect
  /tmp/hda6          2806      2933   1028128+  82  Linux swap

  Disk /tmp/hdb: 255 heads, 63 sectors, 5606 cylinders
  Units = cylinders of 16065 * 512 bytes

     Device Boot    Start       End    Blocks   Id  System
  /tmp/hdb1   *         1      2550  20482843+  83  Linux
  /tmp/hdb2          2551      5606  24547320    5  Extended
  /tmp/hdb5          2551      2805   2048256   fd  Linux raid autodetect
  /tmp/hdb6          2806      2933   1028128+  82  Linux swap

which in turn makes lilo fail, since the root partition start too far from 
the beginning of the disk.

Comment 1 Michael Fulbright 2001-03-08 16:51:45 UTC
What version of Red Hat Linux are you filing this bug for?

Comment 2 Anders Blomdell 2001-03-08 16:55:07 UTC
Latest RawHide (Mon 2000-03-05)


Comment 3 Michael Fulbright 2001-03-08 20:57:42 UTC
Did /etc/lilo get lba32 or linear put in it?

Comment 4 Anders Blomdell 2001-03-09 08:21:21 UTC
/mnt/sysimage/etc/lilo.conf:

boot=/dev/md0
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=linux

image=/boot/vmlinuz-2.4.1-0.1.14
        label=linux
        initrd=/boot/initrd-2.4.1-0.1.14.img
        read-only
        root=/dev/md0


But still screen 0 contains an error message (overwritten by the congratulations 
as usual).

...ning: device 0x0305...
...for linear mode (try...

BUT: the system boots (so the lilo is somewhat OK), and then stops with a:
  Kernel panic: No init found.  


Comment 5 Michael Fulbright 2001-03-09 15:54:17 UTC
Could you try adding a /boot partition so the 1024 cylinder limit isn't a problem?

Comment 6 Anders Blomdell 2001-03-09 16:08:52 UTC
Does this mean that the earlier heuristics that placed / at the beginning of the 
disk is removed, but /boot is still placed at the beginning of the disk?

I would be perfectly satisfied with raiding an already formatted disk, but then 
bug #29544 comes into play.


Comment 7 Michael Fulbright 2001-03-21 20:36:20 UTC
The kickstart code does not properly mark '/' as a bootable partition if '/boot'
is not present currently. I wanted to make sure this was the failure you were
seeing.

Comment 8 Kevin Keegan 2001-06-27 14:15:31 UTC
What is the status of this?  I'm trying to use the following ks.cfg file and 
get the same errors--fatal error "...device 0x0309....try lba32", and system 
will not boot.

part raid.01 --size 25 --ondisk hda
part raid.02 --size 3500 --ondisk hda
part swap --size 300 --ondisk hda

part raid.11 --size 25 --ondisk hdb
part raid.12 --size 3500 --ondisk hdb
part swap --size 300 --ondisk hdb

raid /boot --level 1 --device md0 raid.01 raid.11
raid / --level 1 --device md1 raid.02 raid.12
install


Comment 9 Jeremy Katz 2001-07-22 20:06:46 UTC
New code is much more aggressive about placing /boot partitions or raid
partitions which are part of /boot at the beginning of drives which should fix
this problem.


Note You need to log in before you can comment on or make changes to this bug.