This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 310811 - sound is broken - should be f8 blocker!!
sound is broken - should be f8 blocker!!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
rawhide
x86_64 Linux
low Severity urgent
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 09:01 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 11:21:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Ellson 2007-09-28 09:01:20 EDT
Description of problem:
I am seriously annoyed by the churn, and unnecessary complexity to the user of
the sound system in f8.   Getting sound fixed properly so that it just works
should be a priority issue!

Currently on my system, system-configure-soundcard works ok, but thats it!
gnome-volume-control reports "No volume control GStreamer plugins and/or devices
found."  Sound isn't working for any application, even though they worked up to
about a month ago.

Version-Release number of selected component (if applicable):
gnome-media-2.20.0-2.fc8.x86_64
gstreamer-python-0.10.8-2.fc8.x86_64
gstreamer-devel-0.10.14-3.fc8.x86_64
gstreamer-plugins-good-devel-0.10.6-5.fc8.x86_64
gstreamer-tools-0.10.14-3.fc8.x86_64
bluez-utils-gstreamer-3.19-1.fc8.x86_64
gstreamer-plugins-base-devel-0.10.14-5.fc8.x86_64
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.x86_64
gstreamer-0.10.14-3.fc8.x86_64
gstreamer-plugins-base-0.10.14-5.fc8.x86_64
gstreamer-plugins-farsight-0.12.5-1.fc8.x86_64
gstreamer-plugins-good-0.10.6-5.fc8.x86_64
gstreamer-plugins-schroedinger-0.6.1-3.fc8.x86_64
akode-pulseaudio-2.0.1-8.fc8.x86_64
pulseaudio-module-lirc-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-module-gconf-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-libs-zeroconf-0.9.7-0.13.svn20070925.fc8.i386
pulseaudio-utils-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-libs-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-libs-glib2-0.9.7-0.13.svn20070925.fc8.i386
pulseaudio-esound-compat-0.9.7-0.13.svn20070925.fc8.x86_64
gstreamer-plugins-pulse-0.9.5-0.4.svn20070924.fc8.x86_64
pulseaudio-0.9.7-0.13.svn20070925.fc8.i386
pulseaudio-libs-devel-0.9.7-0.13.svn20070925.fc8.i386
audacious-plugins-pulseaudio-1.3.5-2.fc8.x86_64
pulseaudio-0.9.7-0.13.svn20070925.fc8.x86_64
alsa-plugins-pulseaudio-1.0.14-3.fc8.x86_64
pulseaudio-libs-devel-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-module-x11-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-libs-0.9.7-0.13.svn20070925.fc8.i386
pulseaudio-libs-zeroconf-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-libs-glib2-0.9.7-0.13.svn20070925.fc8.x86_64
pulseaudio-module-zeroconf-0.9.7-0.13.svn20070925.fc8.x86_64
alsa-plugins-upmix-1.0.14-3.fc8.x86_64
alsa-plugins-samplerate-1.0.14-3.fc8.x86_64
python-alsaaudio-0.2-2.fc7.x86_64
alsa-lib-1.0.15-0.2.rc2.fc8.i386
alsa-oss-libs-1.0.14-3.fc8.x86_64
alsa-oss-1.0.14-3.fc8.x86_64
kadu-alsa_sound-0.5.0-4.fc8.x86_64
alsa-plugins-vdownmix-1.0.14-3.fc8.x86_64
alsa-oss-devel-1.0.14-3.fc8.x86_64
callweaver-alsa-1.2-0.3.rc4.20070822.x86_64
alsa-lib-1.0.15-0.2.rc2.fc8.x86_64
alsamixergui-0.9.0-0.3.rc1.fc8.2.x86_64
bluez-utils-alsa-3.19-1.fc8.x86_64
alsa-lib-devel-1.0.15-0.2.rc2.fc8.x86_64
alsa-plugins-pulseaudio-1.0.14-3.fc8.x86_64
alsa-plugins-jack-1.0.14-3.fc8.x86_64
alsa-tools-1.0.12-4.fc7.x86_64
alsa-plugins-oss-1.0.14-3.fc8.x86_64
alsa-utils-1.0.15-0.3.rc1.fc8.x86_64


How reproducible:
100% today

Steps to Reproduce:
1.Open Volume Control
2.
3.
  
Actual results:
No volume control GStreamer plugins and/or devices found.

Expected results:
beautiful sound

Additional info:
Comment 1 Bastien Nocera 2007-09-28 09:13:32 EDT
Is SELinux running? Do applications other than system-config-soundcard run when
run as root?
Comment 2 John Ellson 2007-09-28 09:21:28 EDT
selinux is in permissive mode

of apps as root?   I've not noticed any problems.  e.g. yum, yumex are ok.
Comment 3 Bastien Nocera 2007-09-28 09:59:27 EDT
I meant applications that use sound. I figured the rest was working.
Comment 4 John Ellson 2007-09-28 10:45:09 EDT
Ah, sorry, yes OK.

Running gnome-volume-control as root seems to work,   enabling aux input
allows sound from tvtime running as root.

Comment 5 Bastien Nocera 2007-09-28 11:18:06 EDT
David, what was the bug number for the problem with not setting sound device
nodes permissions properly?
Comment 6 John Ellson 2007-09-28 11:21:57 EDT
It seems I should have added Console-Kit* to the above list!   Who knew!!

Console-kit wasn't running.


I'm still astounded by the complexity and the near impossibility for a regular
user to debug sound problems, and by the churn in in the packages related to
sound, but in this case the problem seems to be caused by me disabling Console-Kit.

Sorry.
Comment 7 John Ellson 2007-09-28 11:23:54 EDT
re#5   #310721 perhaps?   I closed that one too as not-a-bug.
Comment 8 David Zeuthen 2007-09-28 17:33:12 EDT
This bug is closed but there's an interesting bit here we may want to look at:
We really need to fix the OS so users don't randomly turn off critical system
services and then expect the system to work. And when it doesn't then bugs are
filed and that eats up developer time.

We can't really blame such users; after all we provide system-config-services
and there's little or no hint that service XYZ is a critical part of the
(desktop) OS or whether it's something that can be turned off. Users are left to
experiment and then sometimes files bogus bugs resulting in developer time being
wasted (I mean no offense John) . So perhaps we should look at starting identify
what the critical services are and then moving them to rc.sysinit?

Bill, what are your thoughts?
Comment 9 John Ellson 2007-09-28 18:00:07 EDT
Also, the error messages from programs like gnome-volume-control could be
improved if an essential service is missing.

It doesn't help that the <F1> key in ntsysv doesn't work as advertised.

Nor that other new daemons like NetworkManager totally break previously working
configurations.

OK, OK, I guess this isn't the place for a general laundry list.   Just add my
+1 to comment #8.
Comment 10 Bastien Nocera 2007-09-28 21:25:24 EDT
(In reply to comment #9)
> Also, the error messages from programs like gnome-volume-control could be
> improved if an essential service is missing.

Feel free to file a bug, and I'll look into improving the error message for this
program. A good use of your time would be to go through all the default
installed programs that use sound and file bugs for those with error messages
that aren't so useful.
Comment 11 Bill Nottingham 2007-09-28 21:57:02 EDT
Hm, I suppose CK isn't really a good candidate for system activation, as it
relies on login state that it won't have if it's activated later. Or can the PAM
module activate it?

If we move to system activation for some of these services, it makes it harder
to fall into that trap.
Comment 12 David Zeuthen 2007-10-01 16:24:04 EDT
(In reply to comment #11)
> Hm, I suppose CK isn't really a good candidate for system activation, as it
> relies on login state that it won't have if it's activated later. Or can the PAM
> module activate it?

Possibly.

> If we move to system activation for some of these services, it makes it harder
> to fall into that trap.

I'm saying that critical services for the desktop that can't be activated such as

 dbus-daemon --system
 ConsoleKit
 hald
 NetworkManager
 avahi
 cups

ought to be started from /etc/rc.sysinit (just like udevd is). Anything else
(such as Bluetooth daemon, smartd etc.) should be started only when the hardware
is detected or when it's used (ideally we'd move cups to that too) using udev or
hal.

(As a side-effect, the set of initscripts needed for a desktop system would
rapidly approach zero. We probably wouldn't boot any faster though.)

Note You need to log in before you can comment on or make changes to this bug.