Bug 31096 - Xft? Rendering errors with KDE + AA fonts
Xft? Rendering errors with KDE + AA fonts
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Mike A. Harris
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 15:04 EST by Chris Evans
Modified: 2008-05-01 11:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-17 15:28:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Konqueror, AA fonts, LuciduxSans, 12 point min size (196.28 KB, image/png)
2001-03-13 15:33 EST, Chris Evans
no flags Details
Konqueror + AA Helmet font, min point size 10 (142.08 KB, image/png)
2001-03-13 15:44 EST, Chris Evans
no flags Details

  None (edit)
Description Chris Evans 2001-03-08 15:04:58 EST
Hi,
I'm running KDE with anti aliased fonts on.
.
Unfortunately, many of the true type fonts do not render perfectly.
I'm not sure if the X render extension is broken, the ttfonts are
broken, FreeType isn't prime-time yet or what.
.
Examples:
All of these are with Konqueror pointed on http://slashdot.org/
My minimum font size is 12. Font size itself is set to "medium".
.
1) Set font to "Helmet". The following glyphs are rendered
incorrectly: bold "e" (it's drawn solid). bold "s" (two halves not
connected). etc.

2) Set font to "Timmons", and: "g" has its top missing. italic "y"
is twice as faint as any other glyph. etc.

3) Set font to "Utopia", and: italic "g" has the enclosed loop
rendered practically solid

4) Ouch - set font size to 16, with "Helmet" or "Timmons", and
Konqueror font rendering fails totally. Dropping size to 12 and
refreshing restores it.

Also, generally at smaller sizes, rendering is messy - some glyph
edges are noticeably thicker or thinner than all the other glyphs.
Nothing too bad but it gives a slightly unpolished look.

Perhaps this bug needs to be copied to the FreeType and/or
X render folks?
Comment 1 Bernhard Rosenkraenzer 2001-03-12 12:50:22 EST
Looks like a bug in the Xrender extension to me, espeically since it's not 
happening on my hardware (Matrox G400).

Comment 2 Chris Evans 2001-03-13 15:33:40 EST
Created attachment 12627 [details]
Konqueror, AA fonts, LuciduxSans, 12 point min size
Comment 3 Chris Evans 2001-03-13 15:37:29 EST
Hi,
The attachment shows the sloppy rendering with the default
AA font on Konqueror. It's not too bad, but note the problem
with the italics, e.g.
word "Looks" shows "o" glyphs considerably bolder than others.
"F", "w", "c" etc. all also too bold.
Problem worse the smaller the fonts.
Other glyphs are too narrow, e.g. "d"
.
Some of the other TT fonts are worse. I'll attach another picture.
.
I suspect FreeType or the fonts themselves. I'll endevour to try
the Windows TT fonts.
Comment 4 Chris Evans 2001-03-13 15:44:51 EST
Created attachment 12628 [details]
Konqueror + AA Helmet font, min point size 10
Comment 5 Chris Evans 2001-03-13 15:47:18 EST
And the 2nd shot shows problems with the bold fonts. It
happens with larger font sizes too.
Also note in the italic text of the first story, the huge gap
between first and subsequent letters of the words
"operating" and "specifically".
Comment 6 Mike A. Harris 2001-03-17 19:07:38 EST
Should be fixed in XFree86-4.0.2a-2
Comment 7 Chris Evans 2001-04-08 20:02:37 EDT
Unable to verify; anti-aliased fonts totally hosed
with qa0401.

Note You need to log in before you can comment on or make changes to this bug.