Bug 310971 - resource agents probe more often than configured
Summary: resource agents probe more often than configured
Status: CLOSED DUPLICATE of bug 310981
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: rgmanager   
(Show other bugs)
Version: 4
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Lon Hohberger
QA Contact: Cluster QE
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-09-28 13:54 UTC by Lon Hohberger
Modified: 2009-07-22 19:20 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-28 15:05:14 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Fix (6.13 KB, patch)
2007-09-28 13:54 UTC, Lon Hohberger
no flags Details | Diff

Description Lon Hohberger 2007-09-28 13:54:03 UTC
Description of problem:
The metadata in the fs.sh resource agent suggests that the default poll interval
is 2m:

        <!-- Checks to see if it's mounted in the right place -->
        <action name="status" interval="2m" timeout="10"/>
        <action name="monitor" interval="2m" timeout="10"/>

        <!-- Note: active monitoring is constant and supplants all
             check depths -->
        <!-- Checks to see if we can read from the mountpoint -->
        <action name="status" depth="10" timeout="30" interval="2m"/>
        <action name="monitor" depth="10" timeout="30" interval="2m"/>

        <!-- Checks to see if we can write to the mountpoint (if !ROFS) -->
        <action name="status" depth="20" timeout="30" interval="2m"/>
        <action name="monitor" depth="20" timeout="30" interval="2m"/>

When debug is enabled, syslog seems to show the script polling around every 1m:

Mar 12 09:20:26 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:21:27 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:22:27 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:22:37 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:23:29 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:24:28 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:24:39 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:25:29 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)


Version-Release number of selected component (if applicable):
1.9.63-1 (hotfix)

How reproducible:
100%

Steps to Reproduce:
1. Configure a filesystem resource that uses the fs.sh agent in cluster.conf
2. Enable debug logging
3. Start cluster services and enable the service using the file system resource
configured in 1.
  
Actual results:
Probe interval as logged to syslog appears to be 1m.

Expected results:
Probe interval matches configuration information in fs.sh

Comment 1 Lon Hohberger 2007-09-28 13:54:03 UTC
Created attachment 210401 [details]
Fix

Comment 3 Lon Hohberger 2007-09-28 15:05:14 UTC

*** This bug has been marked as a duplicate of 310981 ***


Note You need to log in before you can comment on or make changes to this bug.