Bug 310981 - resource agents probe more often than configured
resource agents probe more often than configured
Status: CLOSED ERRATA
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: rgmanager (Show other bugs)
4
All Linux
urgent Severity medium
: ---
: ---
Assigned To: Lon Hohberger
Cluster QE
:
: 310971 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-28 09:55 EDT by Bryn M. Reeves
Modified: 2010-10-22 15:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: RHBA-2007-1000
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-21 16:53:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch from Lon for the RHEL5 rgmanager (3.65 KB, patch)
2007-09-28 09:55 EDT, Bryn M. Reeves
no flags Details | Diff
RHEL4 patch (6.13 KB, patch)
2007-09-28 10:48 EDT, Lon Hohberger
no flags Details | Diff
ancillary patch to prevent all levels from checking sequentially (941 bytes, patch)
2007-09-28 11:38 EDT, Lon Hohberger
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2007-09-28 09:55:30 EDT
+++ This bug was initially created as a clone of Bug #235178 +++

Description of problem:
The metadata in the fs.sh resource agent suggests that the default poll interval
is 2m:

        <!-- Checks to see if it's mounted in the right place -->
        <action name="status" interval="2m" timeout="10"/>
        <action name="monitor" interval="2m" timeout="10"/>

        <!-- Note: active monitoring is constant and supplants all
             check depths -->
        <!-- Checks to see if we can read from the mountpoint -->
        <action name="status" depth="10" timeout="30" interval="2m"/>
        <action name="monitor" depth="10" timeout="30" interval="2m"/>

        <!-- Checks to see if we can write to the mountpoint (if !ROFS) -->
        <action name="status" depth="20" timeout="30" interval="2m"/>
        <action name="monitor" depth="20" timeout="30" interval="2m"/>

When debug is enabled, syslog seems to show the script polling around every 1m:

Mar 12 09:20:26 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:21:27 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:22:27 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:22:37 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:23:29 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:24:28 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:24:39 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)
Mar 12 09:25:29 testhost1 clurgmgrd[28859]: <debug> status on fs:test1_archiv
returned 0 (success)


Version-Release number of selected component (if applicable):
1.9.63-1 (hotfix)

How reproducible:
100%

Steps to Reproduce:
1. Configure a filesystem resource that uses the fs.sh agent in cluster.conf
2. Enable debug logging
3. Start cluster services and enable the service using the file system resource
configured in 1.
  
Actual results:
Probe interval as logged to syslog appears to be 1m.

Expected results:
Probe interval matches configuration information in fs.sh
Comment 1 Bryn M. Reeves 2007-09-28 09:55:30 EDT
Created attachment 210411 [details]
patch from Lon for the RHEL5 rgmanager
Comment 3 Lon Hohberger 2007-09-28 10:48:31 EDT
Created attachment 210551 [details]
RHEL4 patch
Comment 4 Lon Hohberger 2007-09-28 11:05:15 EDT
*** Bug 310971 has been marked as a duplicate of this bug. ***
Comment 6 Lon Hohberger 2007-09-28 11:17:03 EDT
Patch in CVS
[lhh@ayanami rgmanager]$ cvs commit -m "Fix #310981 - status check timers wrong"
ChangeLog  src/daemons/groups.c src/daemons/resrules.c src/daemons/restree.c 
Checking in ChangeLog;
/cvs/cluster/cluster/rgmanager/ChangeLog,v  <--  ChangeLog
new revision: 1.5.2.32; previous revision: 1.5.2.31
done
Checking in src/daemons/groups.c;
/cvs/cluster/cluster/rgmanager/src/daemons/groups.c,v  <--  groups.c
new revision: 1.8.2.21; previous revision: 1.8.2.20
done
Checking in src/daemons/resrules.c;
/cvs/cluster/cluster/rgmanager/src/daemons/resrules.c,v  <--  resrules.c
new revision: 1.9.2.8; previous revision: 1.9.2.7
done
Checking in src/daemons/restree.c;
/cvs/cluster/cluster/rgmanager/src/daemons/restree.c,v  <--  restree.c
new revision: 1.10.2.17; previous revision: 1.10.2.16
done
Comment 7 Lon Hohberger 2007-09-28 11:38:31 EDT
Created attachment 210661 [details]
ancillary patch to prevent all levels from checking sequentially
Comment 11 errata-xmlrpc 2007-11-21 16:53:19 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-1000.html

Note You need to log in before you can comment on or make changes to this bug.