Bug 31136 - iptables-restore fails on user-defined chains
iptables-restore fails on user-defined chains
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: iptables (Show other bugs)
1.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-08 21:11 EST by Ben Liblit
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 10:43:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Liblit 2001-03-08 21:11:51 EST
The iptables-restore program fails if the saved configuration uses any
user-defined chains as jump targets.  To show this in action, start off
with a clean system with no iptables rules defined.  Run the following
commands:

	# iptables -N user-chain
	# iptables -A INPUT -j user-chain
	# service iptables save
	# service iptables restart

After thre restart command you will see the following diagnostic output:

	iptables-restore v1.2: Couldn't load target
`user-chain':/lib/iptables/libipt_user-chain.so:
	cannot open shared object file: No such file or directory

	Try `iptables-restore -h' or 'iptables-restore --help' for more
information.

An "iptables -L" command confirms that the tables have not been restored. 
Direct inspection of the saved "/etc/sysconfig/iptables" file reveals no
problems in the file itself, suggesting that the bug is on the
iptables-restore side rather than the iptables-save side.

I observe this bug in the "iptables-1.2.0-10" RPM.
Comment 1 Gerald Teschl 2001-03-21 04:33:49 EST

*** This bug has been marked as a duplicate of 28412 ***
Comment 2 David Lawrence 2001-03-21 10:42:21 EST
Reopening bug since it was marked as a duplicate of a private bug which has not
been resolved yet. Bero, please add a comment to this bug on what the fix is
when the private bug is resolved.
Comment 3 Bernhard Rosenkraenzer 2001-03-21 15:29:13 EST
Fixed in 1.2.1a-1

Note You need to log in before you can comment on or make changes to this bug.