Bug 31194 - upgrade 3.0.3 to 7.1 (qa0308.0) lilo hosed
upgrade 3.0.3 to 7.1 (qa0308.0) lilo hosed
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Matt Wilson
Brock Organ
:
: 26790 26910 28280 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 12:45 EST by David Lawrence
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-09 18:29:21 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
old lilo.conf file (lilo.conf.rpmsave) (122 bytes, text/plain)
2001-03-09 12:47 EST, David Lawrence
no flags Details
new lilo.conf file (166 bytes, text/plain)
2001-03-09 12:47 EST, David Lawrence
no flags Details

  None (edit)
Description David Lawrence 2001-03-09 12:45:26 EST
Encountered a problem with lilo.conf when upgrading a 3.0.3 system to
qa0308.0.  The lilo.conf that anaconda wrote would not boot properly since
the old 3.0.3 kernel was still
trying to load. Here is the lilo.conf from the 3.0.3 system before upgrade
(taken from lilo.conf.rpmsave)

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
image=/vmlinuz
	label=linux
	root=/dev/hda5
	read-only


Here is the lilo.conf as written by anaconda for post reboot

boot=/dev/hda
map=/boot/map
install=/boot/boot.b
prompt
timeout=50
message=/boot/message
linear
default=linux

image=/vmlinuz
	label=linux
	root=/dev/hda5
	read-only

As you can see the old kernel is still being used as the default image. It
should read

image=/boot/vmlinuz

to boot the new 2.4.2 kernel instead of the old 1.2.13 kernel.
Comment 1 David Lawrence 2001-03-09 12:47:08 EST
Created attachment 12202 [details]
old lilo.conf file (lilo.conf.rpmsave)
Comment 2 David Lawrence 2001-03-09 12:47:32 EST
Created attachment 12203 [details]
new lilo.conf file
Comment 3 Glen Foster 2001-03-09 18:29:16 EST
This defect considered MUST-FIX (show-stopper) for Florence Gold
Comment 4 Matt Wilson 2001-03-16 00:00:06 EST
Fixed in cvs.
Comment 5 Matt Wilson 2001-03-27 12:15:42 EST
*** Bug 28280 has been marked as a duplicate of this bug. ***
Comment 6 Matt Wilson 2001-04-02 11:33:48 EDT
*** Bug 26790 has been marked as a duplicate of this bug. ***
Comment 7 Matt Wilson 2001-04-02 11:34:43 EDT
*** Bug 26910 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.