Bug 312221 - yum failes and the trace shows a python problem in /usr/lib/python2.5/threading.py
yum failes and the trace shows a python problem in /usr/lib/python2.5/threadi...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Luke Macken
Fedora Extras Quality Assurance
http://pastebin.com/me9b0c66
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-29 05:21 EDT by Eliran Itzhak
Modified: 2014-01-21 17:59 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.1.10-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-25 14:52:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Eliran Itzhak 2007-09-29 05:21:16 EDT
Description of problem:
yum fails everytime I try to yum search or yum install with the same error every
time.

Version-Release number of selected component (if applicable):
yum-3.2.5-1.fc7
python-2.5-12.fc7
kernel-2.6.22.7-85.fc7

How reproducible:
yum search xxx
yum install xxx


Steps to Reproduce:
1.
2.
3.
  
Actual results:
[root@main ~]# yum search kernel
Loading "downloadonly" plugin
Loading "fastestmirror" plugin
Determining fastest mirrors
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in <module>
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 102, in main
    result, resultmsgs = base.doCommands()
  File "/usr/share/yum-cli/cli.py", line 279, in doCommands
    return self.yum_cli_commands[self.basecmd].doCommand(self, self.basecmd,
self.extcmds)
  File "/usr/share/yum-cli/yumcommands.py", line 374, in doCommand
    return base.search(extcmds)
  File "/usr/share/yum-cli/cli.py", line 844, in search
    for (po, matched_value) in matching:
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 1245, in
searchGenerator
    for sack in self.pkgSack.sacks.values():
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 521, in <lambda>
    pkgSack = property(fget=lambda self: self._getSacks(),
  File "/usr/lib/python2.5/site-packages/yum/__init__.py", line 381, in _getSacks
    self.repos.populateSack(which=repos)
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 211, in populateSack
    self.doSetup()
  File "/usr/lib/python2.5/site-packages/yum/repos.py", line 66, in doSetup
    self.ayum.plugins.run('postreposetup')
  File "/usr/lib/python2.5/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/fastestmirror.py", line 80, in postreposetup_hook
    repomirrors[str(repo)] = FastestMirror(repo.urls).get_mirrorlist()
  File "/usr/lib/yum-plugins/fastestmirror.py", line 124, in get_mirrorlist
    self._poll_mirrors()
  File "/usr/lib/yum-plugins/fastestmirror.py", line 132, in _poll_mirrors
    pollThread.start()
  File "/usr/lib/python2.5/threading.py", line 434, in start
    _start_new_thread(self.__bootstrap, ())
thread.error: can't start new thread


Expected results:


Additional info:
Comment 1 Eliran Itzhak 2007-09-29 05:23:05 EDT
Forgot to say in my original bugzilla post.
I statred getting this error yesterday, after the latest yum update.
Until then, Never had such a problem with yum.
I've made no special changes to the system, just yum updated.
Thanks.
Comment 2 Eliran Itzhak 2007-09-29 05:41:58 EDT
I've just found out that the problem is with a yum plugin called "fastestmirror".
If I do "yum search kernel --disableplugin=fastestmirror" everything works well.
The problem started yesterday, and I've made no changes to the system except yum
update.

I have the following yum plugins installed. "downloadonly" & "fastestmirror"

I've removed "yum-fastestmirror" (the problem went away) and reinstalled it (the
problem came back)
Comment 3 Tim Lauridsen 2007-09-29 09:17:36 EDT
Yes, as you already have detected does the problem occours in the fastestmirror
plugin.

Luke, Any comments
Comment 4 Luke Macken 2007-12-07 06:57:28 EST
I patched fastestmirror the other day to make it throttle the way it dispatches
threads.  It adds a 'maxthreads' configuration option, which defaults to 15. 

Please put this file in /usr/lib/yum-plugins and try and reproduce the issue.

http://devel.linux.duke.edu/gitweb/?p=yum-utils.git;a=blob_plain;f=plugins/fastestmirror/fastestmirror.py;hb=a112f75c93c33b6e8f7b59a1e4694f0aecbf9f5e
Comment 5 Luke Macken 2008-01-25 14:52:18 EST
yum-fastestmirror-1.1.10 has been out for a while now, which should resolve this
issue.  Please re-open this bug if this problem still occurs.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.