Bug 31237 - RFE: Allow FTP/HTTP installs from loopback mounted ISOs
RFE: Allow FTP/HTTP installs from loopback mounted ISOs
Status: CLOSED DUPLICATE of bug 29811
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-09 17:02 EST by Jeff Norden
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-11 16:15:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Norden 2001-03-09 17:02:07 EST
First (and this isn't a bug) the installer now needs *both* cdroms for even
a simple workstation install.  Since this is a big change from 7.0, I hope
that it will be prominently mentioned in the "what's new" section when 7.1
is officially released.

I tried to do a network install using ftp from a server where the
iso-images of the disks are mounted via the loopback device.  When the
install got to the point of looking for packages from the second cd, it
just hung up.  Switching to console-3 showed it was simply in an infinite
loop of trying to retrieve tetex-latex.rpm over and over.  It should
eventually give up and give the naive user some sort of error message. 
Even better, it could inform the user of the missing package and ask for an
alternative location to try to find it.  Better yet, the installer could
also allow the user to specify multiple install directories right from the
start.

BTW - it is still possible to do a network install via ftp without
"unpacking" the iso images.  Just mount each of them on a separate
directory and then create a third directory which consists of symbolic
links into the two iso-image directories.  I tried this and it worked fine.
Comment 1 Michael Fulbright 2001-03-09 18:11:30 EST
The request for handling this case has been added to a future feature list.

If you copy both CDs into a single NFS directory, everything proceeds ok?
Comment 2 Jeff Norden 2001-03-17 13:23:14 EST
Unfortunately, I haven't tried an NFS install.  I'm sure that FTP would will
work if you copy both CD's into a single directory.  I did an ftp install by a
slightly different method.  I already had both iso-images on the server and
didn't want to use up an additional 1.2gig by copying the files from the images
into a directory.  I mounted the iso's onto directories disc1/ and disc2/, and
then did the following steps:

1) mkdir install/; cd install/; ln -s ../disc1/* .
   ( now install/ is equivalent to disc1/ )
2) rm RedHat; mkdir RedHat; cd RedHat; ln -s ../../disc1/RedHat/* .
   ( install/ and disc1/ are still equiv, but RedHat isn't a symlink )
3) rm RPMS; mkdir RPMS; cd RPMS; ln -s ../../../disc[12]/RedHat/RPMS/* .
   ( now install/ has symlinks for the RPMS from both disks )

I then did an ftp install from the install/ directory, and everything worked
perfectly.

---

I did notice that the current "install guide" still mentions doing an NFS
install from a remotely mounted CDROM drive.  I wonder if this works correctly -
i.e., is the user prompted to change the CD, and will it be possible to umount
the cd and then mount the second CD on the server machine?
Comment 3 Michael Fulbright 2001-03-20 12:13:30 EST
Thanks for the information.  We have thought about making it possible to mount
the ISOs individually and allows installs remotely, we just haven't had time to
work on this.

I'm deferring this for future consideration.
Comment 4 Michael Fulbright 2001-04-11 16:15:19 EDT

*** This bug has been marked as a duplicate of 29811 ***

Note You need to log in before you can comment on or make changes to this bug.