Bug 312681 - sound-juicer can't find cdrom on mac mini ppc
sound-juicer can't find cdrom on mac mini ppc
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
7
powerpc Linux
low Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-29 17:20 EDT by Han-Wen Nienhuys
Modified: 2013-03-05 22:52 EST (History)
1 user (show)

See Also:
Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-02 13:55:33 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal output (85.67 KB, text/plain)
2007-09-30 18:37 EDT, Han-Wen Nienhuys
no flags Details

  None (edit)
Description Han-Wen Nienhuys 2007-09-29 17:20:42 EDT
Description of problem:

starting sound-juicer pops up dialog: no CD-ROM drives found
starting with -d /dev/cdrom causes crash:



** ERROR **: file sj-main.c: line 814 (set_drive_from_device): assertion failed:
(drive)
aborting...
Distribution: Fedora release 7 (Moonshine)
Gnome Release: 2.18.3 2007-07-02 (Red Hat, Inc)
BugBuddy Version: 2.18.0

System: Linux 2.6.22.1-33.fc7 #1 Mon Jul 23 16:50:49 EDT 2007 ppc
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: Fedora

Memory status: size: 84025344 vsize: 84025344 resident: 26238976 share: 21004288
rss: 26238976 rss_rlim: 4294967295
CPU usage: start_time: 1191100547 rtime: 76 utime: 69 stime: 7 cutime:12 cstime:
0 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/sound-juicer'

[?1034h(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 810142480 (LWP 6851)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
0x0f1704e4 in waitpid () from /lib/libpthread.so.0
#0  0x0f1704e4 in waitpid () from /lib/libpthread.so.0
#1  0x00740f7c in ?? () from /usr/lib/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x0f485f10 in raise () from /lib/libc.so.6
#4  0x0f487c94 in abort () from /lib/libc.so.6
#5  0x0f2824b4 in g_logv () from /lib/libglib-2.0.so.0
#6  0x0f282528 in g_log () from /lib/libglib-2.0.so.0
#7  0x0f2825cc in g_assert_warning () from /lib/libglib-2.0.so.0
#8  0x10009dd4 in ?? ()
#9  0x1000c5e8 in ?? ()
#10 0x1000dbb8 in main ()

Thread 1 (Thread 810142480 (LWP 6851)):
#0  0x0f1704e4 in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00740f7c in ?? () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#2  <signal handler called>
No symbol table info available.
#3  0x0f485f10 in raise () from /lib/libc.so.6
No symbol table info available.
#4  0x0f487c94 in abort () from /lib/libc.so.6
No symbol table info available.
#5  0x0f2824b4 in g_logv () from /lib/libglib-2.0.so.0
No symbol table info available.
#6  0x0f282528 in g_log () from /lib/libglib-2.0.so.0
No symbol table info available.
#7  0x0f2825cc in g_assert_warning () from /lib/libglib-2.0.so.0
No symbol table info available.
#8  0x10009dd4 in ?? ()
No symbol table info available.
#9  0x1000c5e8 in ?? ()
No symbol table info available.
#10 0x1000dbb8 in main ()
No symbol table info available.
#0  0x0f1704e4 in waitpid () from /lib/libpthread.so.0
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y;
input not from terminal]


----------- .xsession-errors (762 sec old) ---------------------
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
JACK tmpdir identified as [/dev/shm]
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x2400021 (Music Play)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a
timestamp of 0 for 0x2400021 (Music Play)
Window manager warning: meta_window_activate called by a pager with a 0
timestamp; the pager needs to be fixed.
Window manager warning: last_focus_time (1393850224) is greater than comparison
timestamp (1393849568).  This most likely represents a buggy client sending
inaccurate timestamps in messages such as _N
Window manager warning: last_user_time (1393850224) is greater than comparison
timestamp (1393849568).  This most likely represents a buggy client sending
inaccurate timestamps in messages such as _NE
Window manager warning: 0x2400021 (Music Play) appears to be one of the
offending windows with a timestamp of 1393850224.  Working around...
--------------------------------------------------

gnome-cd does manage to play the cd.
Comment 1 Bastien Nocera 2007-09-29 19:26:53 EDT
Do any drives appear in "lshal"?
Could you please install the debuginfo packages and get a useful stacktrace from
the crash (as per http://fedoraproject.org/wiki/StackTraces)?
Comment 2 Han-Wen Nienhuys 2007-09-30 18:37:51 EDT
Created attachment 211941 [details]
lshal output
Comment 3 Han-Wen Nienhuys 2007-09-30 18:38:49 EDT
Distribution: Fedora release 7 (Moonshine)
Gnome Release: 2.18.3 2007-07-02 (Red Hat, Inc)
BugBuddy Version: 2.18.0

System: Linux 2.6.22.1-33.fc7 #1 Mon Jul 23 16:50:49 EDT 2007 ppc
X Vendor: The X.Org Foundation
X Vendor Release: 10300000
Selinux: Permissive
Accessibility: Disabled
GTK+ Theme: Clearlooks
Icon Theme: Fedora

Memory status: size: 84017152 vsize: 84017152 resident: 26226688 share: 21000192
rss: 26226688 rss_rlim: 4294967295
CPU usage: start_time: 1191191693 rtime: 76 utime: 66 stime: 10 cutime:11
cstime: 2 timeout: 0 it_real_value: 0 frequency: 100

Backtrace was generated from '/usr/bin/sound-juicer'

[?1034h(no debugging symbols found)
Using host libthread_db library "/lib/libthread_db.so.1".
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 810142480 (LWP 5926)]
0x0f1704e4 in waitpid () from /lib/libpthread.so.0
#0  0x0f1704e4 in waitpid () from /lib/libpthread.so.0
#1  0x00740f7c in libgnomeui_segv_handle (signum=6) at gnome-ui-init.c:872
#2  <signal handler called>
#3  0x0f485f10 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
#4  0x0f487c94 in *__GI_abort () at abort.c:88
#5  0x0f2824b4 in IA__g_logv (log_domain=0x0, log_level=<value optimized out>, 
    format=0xf2b8cd0 "file %s: line %d (%s): assertion failed: (%s)", 
    args1=0x7fa70444) at gmessages.c:497
#6  0x0f282528 in IA__g_log (log_domain=0x0, log_level=5926, 
    format=0x6 <Address 0x6 out of bounds>) at gmessages.c:517
#7  0x0f2825cc in IA__g_assert_warning (log_domain=0x0, 
    file=0x1001d518 "sj-main.c", line=814, 
    pretty_function=0x1001e254 "set_drive_from_device", 
    expression=0x1001d524 "drive") at gmessages.c:552
#8  0x10009dd4 in ?? ()
#9  0x1000c5e8 in ?? ()
#10 0x1000dbb8 in main ()

Thread 1 (Thread 810142480 (LWP 5926)):
#0  0x0f1704e4 in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#1  0x00740f7c in libgnomeui_segv_handle (signum=6) at gnome-ui-init.c:872
	estatus = 0
	sa = {__sigaction_handler = {sa_handler = 0, sa_sigaction = 0}, 
  sa_mask = {__val = {2141648960, 1, 254026000, 1, 2141649616, 253767468, 
      12491884, 1, 2141649072, 11758692, 0, 272249648, 2141649008, 0, 
      604129412, 100, 2141649040, 0, 0, 0, 22, 2141650504, 257818612, 22, 
      2141649072, 256685016, 4294967291, 254512381, 1, 254512380, 257818612, 
      2141649072}}, sa_flags = 2141650496, 
  sa_restorer = 0xf49d75c <_IO_vfprintf_internal+5580>}
	in_segv = 1
#2  <signal handler called>
No symbol table info available.
#3  0x0f485f10 in *__GI_raise (sig=6)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
	r4 = <value optimized out>
	r7 = <value optimized out>
	r12 = <value optimized out>
	r5 = 6
	r8 = <value optimized out>
	r10 = <value optimized out>
	r0 = 250
	r3 = <value optimized out>
	r6 = <value optimized out>
	r9 = <value optimized out>
	r11 = <value optimized out>
	sc_ret = <value optimized out>
	pd = (struct pthread *) 0x3049cb10
	pid = 0
	selftid = 5926
#4  0x0f487c94 in *__GI_abort () at abort.c:88
	self = (void *) 0x7fa6fe48
	act = {__sigaction_handler = {sa_handler = 0x7fa70444, 
    sa_sigaction = 0x7fa70444}, sa_mask = {__val = {254512336, 254839684, 
      254839352, 254292288, 0, 268647188, 1, 254838628, 0, 254091480, 
      269144656, 268369884, 810095272, 2141650736, 268230756, 256204876, 4, 0, 
      269144656, 5, 4, 6, 269144656, 254867368, 2, 2141650800, 268260208, 
      1107445890, 8, 257823864, 0, 102}}, sa_flags = -16843009, 
  sa_restorer = 0x1}
	sigs = {__val = {32, 0 <repeats 31 times>}}
#5  0x0f2824b4 in IA__g_logv (log_domain=0x0, log_level=<value optimized out>, 
    format=0xf2b8cd0 "file %s: line %d (%s): assertion failed: (%s)", 
    args1=0x7fa70444) at gmessages.c:497
	depth = <value optimized out>
	domain = <value optimized out>
	data = (gpointer) 0x0
	log_func = (GLogFunc) 0xf283140 <IA__g_log_default_handler>
	domain_fatal_mask = 5
	test_level = 269144656
	was_recursion = 0
	i = 2
#6  0x0f282528 in IA__g_log (log_domain=0x0, log_level=5926, 
    format=0x6 <Address 0x6 out of bounds>) at gmessages.c:517
	args = {{gpr = 7 '\a', fpr = 0 '\0', reserved = 24456, 
    overflow_arg_area = 0x7fa70468, reg_save_area = 0x7fa703e0}}
#7  0x0f2825cc in IA__g_assert_warning (log_domain=0x0, 
    file=0x1001d518 "sj-main.c", line=814, 
    pretty_function=0x1001e254 "set_drive_from_device", 
    expression=0x1001d524 "drive") at gmessages.c:552
No locals.
#8  0x10009dd4 in ?? ()
No symbol table info available.
#9  0x1000c5e8 in ?? ()
No symbol table info available.
#10 0x1000dbb8 in main ()
No symbol table info available.
#0  0x0f1704e4 in waitpid () from /lib/libpthread.so.0
The program is running.  Quit anyway (and detach it)? (y or n) [answered Y;
input not from terminal]


----------- .xsession-errors (766 sec old) ---------------------
** (rhythmbox-metadata:2620): WARNING **: Add decoder imc (86046) please
** (rhythmbox-metadata:2620): WARNING **: Add decoder gsm (86037) please
** (rhythmbox-metadata:2620): WARNING **: Add decoder gsm_ms (86049) please
** (rhythmbox-metadata:2620): WARNING **: Add decoder mpc sv7 (86047) please
** (rhythmbox-metadata:2620): WARNING **: Add decoder smackaud (86042) please
** (rhythmbox-metadata:2620): WARNING **: Add decoder wavpack (86044) please
** (rhythmbox-metadata:2620): WARNING **: Add decoder adpcm_thp (69650) please
Window manager warning: GtkMenu failed to grab the pointer
Window manager warning: last_focus_time (1485012991) is greater than comparison
timestamp (1485012990).  This most likely represents a buggy client sending
inaccurate timestamps in messages such as _N
--------------------------------------------------
Comment 4 Bastien Nocera 2007-09-30 19:07:24 EDT
It's asserting here:
    monitor = nautilus_burn_get_drive_monitor ();
    drive = nautilus_burn_drive_monitor_get_drive_for_device (monitor, device);
->  g_assert (drive);

Because libnautilusburn doesn't know about /dev/cdrom, or /dev/hdb being CD
drives. The lshal output shows that:
udi = '/org/freedesktop/Hal/devices/storage_model_MATSHITACD_RW_CW_8123'
  block.device = '/dev/hdb'  (string)
  block.is_volume = false  (bool)
  block.major = 3  (0x3)  (int)
  block.minor = 64  (0x40)  (int)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_model_MATSHITACD_RW_CW_8123'  (string)
<snip>
  storage.drive_type = 'disk'  (string)

Reassigning to HAL. The crash itself is:
http://bugzilla.gnome.org/show_bug.cgi?id=389044
and is fixed in the test versions of Fedora 8.

Note You need to log in before you can comment on or make changes to this bug.