Bug 313071 - kernel / kernel-xen upgrades fail to add grub.conf stanza
kernel / kernel-xen upgrades fail to add grub.conf stanza
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel-xen (Show other bugs)
7
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eduardo Habkost
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 09:43 EDT by David Timms
Modified: 2009-12-14 15:38 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-02 08:34:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
yum log (25.17 KB, text/plain)
2007-09-30 09:43 EDT, David Timms
no flags Details
cat /var/log/yum.log|grep -E 'kernel|yum|init|rpm'|sort (2.96 KB, text/plain)
2007-09-30 09:52 EDT, David Timms
no flags Details
process used to solve the issue. (6.46 KB, text/plain)
2007-10-02 08:31 EDT, David Timms
no flags Details

  None (edit)
Description David Timms 2007-09-30 09:43:59 EDT
Description of problem:
After running pup update 2007-09-30, grub doesn't have entries for the newly
installed normal kernel.

Version-Release number of selected component (if applicable):
kernel-2.6.22.7-85.fc7
kernel-2.6.22.9-91.fc7
kernel-devel-2.6.22.7-85.fc7
kernel-devel-2.6.22.9-91.fc7
kernel-headers-2.6.22.9-91.fc7
kernel-xen-2.6.20-2934.fc7
kernel-xen-2.6.20-2936.fc7
kernel-xen-devel-2.6.20-2934.fc7
kernel-xen-devel-2.6.20-2936.fc7
mkinitrd-6.0.9-7.1
pirut-1.3.9-1.fc7

Steps to Reproduce:
0. Both kernel and kernel-xen are installed.
1. Running 2.6.20-2934.fc7xen {as grub default}
2. pup update
My mirrors didn't have kernel-xen and gcc-fortran at this time. 
3. Unselected kernel-xen and gcc-fortran, apply updates
4. Rerun pup and update, completes.
  
Actual results:
rpm -qa kernel\*|sort
kernel-2.6.22.7-85.fc7
kernel-2.6.22.9-91.fc7
kernel-devel-2.6.22.7-85.fc7
kernel-devel-2.6.22.9-91.fc7
kernel-headers-2.6.22.9-91.fc7
kernel-xen-2.6.20-2934.fc7
kernel-xen-2.6.20-2936.fc7
kernel-xen-devel-2.6.20-2934.fc7
kernel-xen-devel-2.6.20-2936.fc7

## cat /boot/grub/grub.conf  
# grub.conf generated by anaconda
#
# Note that you do not have to rerun grub after making changes to this file
# NOTICE:  You have a /boot partition.  This means that
#          all kernel and initrd paths are relative to /boot/, eg.
#          root (hd0,2)
#          kernel /vmlinuz-version ro root=/dev/sda5
#          initrd /initrd-version.img
#boot=/dev/sda
default=0
timeout=4
splashimage=(hd0,2)/grub/splash.xpm.gz
#hiddenmenu
title Fedora (2.6.20-2936.fc7xen)
        root (hd0,2)
        kernel /xen.gz-2.6.20-2936.fc7
        module /vmlinuz-2.6.20-2936.fc7xen ro root=LABEL=/ rhgb quiet
        module /initrd-2.6.20-2936.fc7xen.img
title Fedora (2.6.20-2934.fc7xen)
        root (hd0,2)
        kernel /xen.gz-2.6.20-2934.fc7
        module /vmlinuz-2.6.20-2934.fc7xen ro root=LABEL=/ rhgb quiet
        module /initrd-2.6.20-2934.fc7xen.img
title Other
        rootnoverify (hd0,0)
        chainloader +1

Expected results:
since both kernel and kernel-xen are installed, both should have entries in
grub.conf.

Additional info: 
see bug 250438 {closed as unrepeatable / lack of information}.
Comment 1 David Timms 2007-09-30 09:43:59 EDT
Created attachment 211721 [details]
yum log
Comment 2 David Timms 2007-09-30 09:52:27 EDT
Created attachment 211731 [details]
cat /var/log/yum.log|grep -E 'kernel|yum|init|rpm'|sort

notice how the kernel-xen was installed:
Sep 30 21:22:18 Installed: kernel-xen.i686 2.6.20-2936.fc7, then again:
Sep 30 22:35:08 Installed: kernel-xen.i686 2.6.20-2936.fc7

Also:
Sep 28 22:38:00 Installed: kernel - 2.6.22.7-85.fc7.i686.fc7.i386
Sep 30 21:21:45 Installed: kernel.i686 2.6.22.9-91.fc7
but there is no entries in grub.conf for the plain kernels in grub.conf.
Comment 3 David Timms 2007-10-02 08:31:06 EDT
Created attachment 213341 [details]
process used to solve the issue.

A resolution of sorts: to get the system to reinsert the proper
/boot/grub/grub.conf stanza:
# yum remove kernel {leaving kernel-xen}
# yum install kernel
error: unpacking of archive failed on file /boot/System.map-2.6.22.9-91.fc7:
cpio: rename
Error unpacking rpm package kernel - 2.6.22.9-91.fc7.i686
# nautilus to view dir about half the files where showing size, user, etc as
--- 
# checked disk space on /, /boot {ok}
# fsck /boot {ok}
# fsck -f /boot   {errors:}
  deleted/unused inode 21 etc.
  Inode 12 ref count is 1, should be 2.  Fix<y>? yes  etc.
# fsck -f /boot {ok}
# yum remove kernel {ok}
# yum install kernel {ok}
{grub entries added OK}

The previous shutdowns had been normal, and no other unreliabilities had been
noted. Perhaps a similar thing had happened to the machine in bug 250438 ?
Comment 4 David Timms 2007-10-02 08:34:35 EDT
I'll leave it open for a while, in case there is similar issues reported, or
feel free to close - resolution=?

Note You need to log in before you can comment on or make changes to this bug.