Bug 313101 - adding or moving an object leaves fragmented graphics
adding or moving an object leaves fragmented graphics
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: glabels (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Peter Gordon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-09-30 10:38 EDT by Gerry Tool
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-13 10:01:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
glabels file for a CD label (108.26 KB, application/octet-stream)
2007-10-13 09:33 EDT, Gerry Tool
no flags Details

  None (edit)
Description Gerry Tool 2007-09-30 10:38:18 EDT
Description of problem:
When moving an image or text item, only part of the item appears to move.
When adding a text item, only part of the text is available.

Version-Release number of selected component (if applicable):
glabels-2.0.4-7.fc8

How reproducible:
Always

Steps to Reproduce:
1.execute glabels
2.move an object or enter new text item
3.
  
Actual results:
only part of object appears to move or text is only partially visible

Expected results:
Total object should appear to move.

Additional info: using nv graphics driver.
Comment 1 Peter Gordon 2007-09-30 16:03:06 EDT
Does this only happen with specific templates or objects?
Comment 2 Gerry Tool 2007-09-30 22:00:15 EDT
I have tried both address label templates and CD label templates.  Both have the
same behavior for either text or image objects.  I will be happy to conduct any
testing you think might help.

I believe I tested glabels in f8t1 without any problems.  The same templates and
existing label files work fine in f7.

In f7

[gerry@fedora7 ~]$ rpm -q glabels
glabels-2.0.4-5.fc6
Comment 3 Peter Gordon 2007-10-07 03:48:38 EDT
Thanks for the bug report, Gerry. 

Also, just to be sure that it's not a graphics driver issue, does this still
occur if you use the "vesa" driver instead of "nv"? 

Also, do you have a sample file that might easily allow me to reproduce this issue?
Comment 4 Gerry Tool 2007-10-13 09:33:12 EDT
Created attachment 226411 [details]
glabels file for a CD label

example requested to see if problem can be duplicated by maintainer.
Comment 5 Gerry Tool 2007-10-13 09:35:27 EDT
yes, the problem still exists with the "vesa" driver.  File submitted for a CD
label.  Select and move one of the text items on the label to see the text
"smear" as it is moved.
Comment 6 Gerry Tool 2007-10-13 10:01:45 EDT
Well, while I was doing the test mentioned above, I was also accepting the many
updates that had accumulated during my week away.

After reboot, this problem no longer exists in glabels, although it is the same
version as before.  As you suspected, it must have been due to some other package.
Comment 7 Peter Gordon 2007-10-13 13:52:20 EDT
Okay! Glad you got it solved. :)

Note You need to log in before you can comment on or make changes to this bug.