This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 31361 - Install V7 fails 'system error 22'
Install V7 fails 'system error 22'
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 14:17 EST by Ghislain Pelletier
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 11:37:55 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ghislain Pelletier 2001-03-10 14:17:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98; Win 9x 4.90)


After packages are selected install fails

Reproducible: Always
Steps to Reproduce:
1.Run Install from floppy boot image obtained from 
sweb.uky.edu/~mabran3/linux/misc (workaround for ata100)
2.Workstation/server/custom install reproduces problem
3.
	

Actual Results:  Recieve abend message.

Traceback (innermost last):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/iw/progress_gui.py", 
line 20, in run
    rc = self.todo.doInstall ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/todo.py", line 1480, in 
doInstall
    if self.method.systemMounted (self.fstab, self.instPath, 
self.hdList.selected()):
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/image.py", line 63, in 
systemMounted
    isys.lochangefd("/tmp/loop",self.loopbackfile)
  File "/usr/lib/anaconda/isys.py",line 55,inlochangefd_isys.lochangefd
(loop.targ)

SystemError: (22, ('invalid argument'))
Comment 1 Michael Fulbright 2001-03-12 11:37:51 EST
Can you try without the workaround floppy? I can't really tell if its a problem
with Red Hat Linux 7.0 or the custom floppy you are using otherwise.
Comment 2 Michael Fulbright 2001-04-02 16:05:15 EDT
Closing due to inactivity - please reopen this report if anything new needs to
be added to it.

Note You need to log in before you can comment on or make changes to this bug.