Bug 31373 - Automatic partitioning with removal of data - default on Custom install
Automatic partitioning with removal of data - default on Custom install
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Trond Eivind Glomsrxd
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 17:20 EST by Inger Karin Haarbye
Modified: 2007-04-18 12:32 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-17 12:24:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Inger Karin Haarbye 2001-03-10 17:20:40 EST
I think it would be better with disk-druid as default with "custom
install". 

Now, Automatic partitioning with removal of data is default - and you get a
warning saying:

"You are about to erase any preexisting Linux installations on your system.
If you don't want to do this, you can continue this install by partitioning
manually, or you can go back and perform a fully customized inatallation."

And:
"If you want to preserve data on existing Linux partitions, you should
chose to partition manually or chose a custom-class installation."

This doesn't make much sense to me - as I already are doing "custom
install".

I thought that default removal of data (as default) belonged to another
installation-class? (workstation?).
Comment 1 Henri Schlereth 2001-03-10 19:04:40 EST
Additionally, the custom install used to never touch /home which it now does. I think I can recover about 80% of the data
from backups, but I can just imagine the customers oh sh*t reaction after it wipes /home, maybe because it did come out
of my mouth too.
Comment 2 Michael Fulbright 2001-03-12 11:30:48 EST
Brent please investigate this.
Comment 3 Glen Foster 2001-03-12 14:40:54 EST
This defect considered MUST-FIX (show-stopper) for Florence Gold
Comment 4 Henri Schlereth 2001-03-12 15:49:38 EST
In all fairness, the first fault is mine. I did not read the full blurb about the auto-partitioning wiping all Linux partitions since I
was looking to test a different error. So my reaction was cool, auto-partioning, wont have to do this crap by hand on the
dual-boot machine anymore. And it very nicely didnt touch the windows partitions.
Oh yeah, the problem I was researching was fixed.

On the flip side, how many other people may react like I did and do what I did. So you may or may not call this a show
stopper or think in terms of how to make people really pay attention to the warning. I was so used to the custom
install process I assumed that the auto-partioning software would use the existing partions and skip /home, which is what
I am used to.

On the other hand the partioning format went for a /boot and a / partition only. Isnt the FHS to have / /boot/ /usr /home /var ?

Comment 5 Brent Fox 2001-03-12 18:54:10 EST
The help text and the screen text are pretty broken.  They assume:
1) That you are doing a workstation install.
2) That you are using Automatic Partitioning.

This may or may not be the case.  Certainly, the part that tells you back up and
do a custom install if you don't want auto partitioning is wrong...especially if
you selected a custom install.
Comment 6 Brent Fox 2001-03-14 10:20:11 EST
Text is fixed in cvs.  Thanks for your report.
Comment 7 Inger Karin Haarbye 2001-04-13 04:06:39 EDT
Seawolf:
The help text (left side of screen) is still not "uptodate" with the default 
automatic partitioning. It sais still something like you can go back and chose 
custom install. (I use norwegian install language).

(And still I don't like this default - some day I'm sure all my disks are 
wiped away "by default". But this is a different story).
Comment 8 Brent Fox 2001-04-13 10:28:03 EDT
We changed it in English...I guess the Norwegian translations didn't make it
back in time.  Will fix in future release.
Comment 9 Brent Fox 2001-04-17 12:24:23 EDT
Trond, since you speak Norwegian, can you fix the docs?
Comment 10 Trond Eivind Glomsrxd 2001-04-17 16:00:54 EDT
I've submitted the fix to CVS.

Note You need to log in before you can comment on or make changes to this bug.