Bug 31380 - Why restart X on logging out from Gnome or KDE?
Why restart X on logging out from Gnome or KDE?
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: gdm (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 18:28 EST by Alexei Podtelezhnikov
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-10 20:11:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Alexei Podtelezhnikov 2001-03-10 18:28:01 EST
From Bugzilla Helper:

Using gdm to login doesn't touch X. Logging out from KDE or Gnome, on the 
contrary, restarts the entire X. I'd assume that this behavior is 
suboptimal and wrong. X is big and should be preserved in memory. This 
causes huge memory stress for the system and the blinking is not very 
healthy for the monitor.

Reproducible: Always
Steps to Reproduce:
1. Use graphical login
2. Login, then logout...
3. Watch for pid of X...
	
Actual Results:  X gets restarted - its PID changes and the screen is 
blinking.

Expected Results:  Preserve X from restarting and video mode from changing 
back and forth.
Comment 1 Havoc Pennington 2001-03-10 20:44:26 EST
There's nothing to be gained by keeping X in memory, and no monitor that I know
suffers adverse consequences from swapping video modes (since all PCs do this
every time they're restarted, and many PCs are power-cycled several times a day
for years with no damage to the monitor). The restart lets new logins use a
"clean slate," which may reduce memory usage, probably increases stability a
bit, and keeps users from playing dirty tricks on each other.
Comment 2 Alexei Podtelezhnikov 2001-03-11 00:03:42 EST
Of all your arguments I only agree with "clean state". As for dirty tricks, 
what could be worse than restarting X on a system with multiple remote X 
terminals? Plus, log out does take a few seconds to comlete even on a modern 
system with Athlon 750 MHz. I suppose 90% of this time is restarting X.

RedHat has two options - graphical and text login. I think they must have a 
meaning besides esthetic one. Text mode should be used to achive "clean state" 
and prevent dirty tricks. Graphical mode should be used when X needs 
uninterrupted execution as on systems with multiple X users.

Note You need to log in before you can comment on or make changes to this bug.