Bug 31391 - Mailman HTML interface not working (not parsed by python?)
Mailman HTML interface not working (not parsed by python?)
Status: CLOSED CURRENTRELEASE
Product: Red Hat Secure Web Server
Classification: Retired
Component: mailman (Show other bugs)
2.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-10 20:16 EST by Kev 'Kyrian' Green
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-03-13 16:10:45 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kev 'Kyrian' Green 2001-03-10 20:16:27 EST
Hi,

I've installed both of the following at different times on my machine 
running a (highly upgraded, but probably not 100% up to date) RedHat 6.l 
machine:

mailman-2.0beta2-1.i386.rpm
mailman-2.0beta5-1.i386.rpm

They don't report any errors of dependancies etc. when I install them, and 
don't report any errors when I create a list with them, but when I try to 
view the HTML interface for the list I just created, I get loads of what 
look to be python variables which have not been replaced with their 
respective values for the list in question. ie [ for a list named 'spiky', 
at http://mailman.ore.org/lists/spiky/options.html ]:

--- BEGIN options.html ---
<!-- $Revision: 1.18 $ -->
<html>
<head>
<title><MM-Presentable-User> Configuration for <MM-List-Name></title>

</head>
<BODY BGCOLOR="#ffffff">
        <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="5">
        <TR><TD WIDTH="100%" BGCOLOR="#99CCFF"><B>
        <FONT COLOR="#000000" SIZE=+1>
<MM-List-Name> Configuration for <MM-Presentable-User>
        </FONT></B></TD></TR> </TABLE>
<MM-Form-Start>

<p>

<b><MM-Presentable-User></b>'s subscription status,
password, and options for the <MM-List-Name> mailing list.
<MM-Case-Preserved-User>

<MM-Disabled-Notice>

<p>

<a name=unsub>
        <TABLE WIDTH="100%" BORDER="0" CELLSPACING=5" CELLPADDING="5">
        <TR><TD WIDTH="50%" BGCOLOR="#FFF0D0"><FONT COLOR="#000000">
<B>Unsubscribing from <MM-List-Name></B>
        <TD WIDTH="50%" BGCOLOR="#FFF0D0"><FONT COLOR="#000000">
<B>Your other <MM-Host> subscriptions</B>
        </FONT></TD></TR>

        <tr>
          <td>

To unsubscribe, enter your password and hit the button.  (If you've
lost your password, see just below to have it emailed to you.)

<p>
Password: <MM-Unsub-Pw-Box> &nbsp;
<MM-Unsubscribe-Button>
</a>
          <td>

Enter your password to visit a list of links to option pages for
all your subscriptions.

<p>
Password: <MM-Other-Subscriptions-Pw-Box>  
<MM-Other-Subscriptions-Submit><p>

        </TD></TR> </table>

        <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="5">
        <TR><TD COLSPAN=2 WIDTH="100%" BGCOLOR="#FFF0D0"><FONT 
COLOR="#000000">
<B>Your <MM-List-Name> Password</B>
        </FONT></TD>
</TR>
<tr valign="TOP">
<td WIDTH="50%">
<a name=reminder>
<center>
<h3>Forgotten Your Password?</h3>
</center>
Click this button to have your password emailed to your list delivery
address. <p>
<MM-Umbrella-Notice>
<center>
<MM-Email-My-Pw>
</center>
</td>
<td WIDTH="50%">
<a name=changepw>
<center>
<h3>Change Your Password</h3>
      <TABLE BORDER="0" CELLSPACING="2" CELLPADDING="2" WIDTH="70%" COLS=2>
      <TR>
        <TD WIDTH="30%" BGCOLOR="#dddddd">Old password:</TD>
        <TD WIDTH="70%"><MM-Old-Pw-Box></TD>
      </TR>
      <TR>
        <TD BGCOLOR="#dddddd">New password:</TD>
        <TD><MM-New-Pass-Box></TD>
      </TR>
      <TR> 
        <TD BGCOLOR="#dddddd">Again to confirm:</TD>
        <TD><MM-Confirm-Pass-Box></TD>
      </TR>
</table>
           <MM-Change-Pass-Button>
    </TABLE>

<p>

<a name=options>
        <TABLE WIDTH="100%" BORDER="0" CELLSPACING="0" CELLPADDING="5">
        <TR><TD WIDTH="100%" BGCOLOR="#FFF0D0"><FONT COLOR="#000000">
<B>Your <MM-List-Name> Subscription Options</B>
        </FONT></TD></TR> </table>

<p>
<i><strong>Current values are checked.</strong></i><p>
<p>
<TABLE BORDER="0" CELLSPACING="2" CELLPADDING="3" WIDTH="80%">
<tr><TD BGCOLOR="#dcdcdc">
<a name="disable">
<strong> Disable mail delivery </strong> <br>
Turn this on if you want mail to not be delivered to you for a little 
while.<br>
<mm-delivery-enable-button> Off
<mm-delivery-disable-button> On <p>
</a>
</td></tr>
<tr><TD BGCOLOR="#dcdcdc">
<strong> Set Digest Mode</strong> <br>
If you turn digest mode on, you'll get posts bundled together once a
day, instead singly when they're sent.  If digest mode is changed from 
on to off, you will receive one last digest.<br>
<MM-Undigest-Radio-Button> Off
<MM-Digest-Radio-Button> On<br>
</td></tr>
<tr><TD BGCOLOR="#dcdcdc">
<strong> Get MIME or Plain Text Digests?</strong> <br>
If you have any problems with MIME digests, select plain text. <br>
<MM-Mime-Digests-Button> MIME
<MM-Plain-Digests-Button> Plain Text <p>
</td></tr>
<tr><TD BGCOLOR="#dcdcdc">
<strong> Receive posts you send to the list? </strong><br>
<mm-receive-own-mail-button> Yes
<mm-dont-receive-own-mail-button> No <p>
</td></tr>
<tr><TD BGCOLOR="#dcdcdc">
<strong> Receive acknowledgement mail when you send mail to the list? 
</strong><br>
<mm-dont-ack-posts-button> No
<mm-ack-posts-button> Yes <p>
</td></tr>
<tr><TD BGCOLOR="#dcdcdc">
<strong> Conceal yourself from subscriber list? </strong><br>
<MM-Public-Subscription-Button> No
<MM-Hide-Subscription-Button> Yes <p>
</td></tr>
<tr><TD BGCOLOR="#dcdcdc">
Password: <MM-Digest-Pw-Box>  <MM-Digest-Submit><p>
</td></tr></table>
</center>

<p>
<MM-Form-End>

<MM-Mailman-Footer>
</body>
</html>

--- END options.html ---

I also tried installing mailman manually (without RPM), and it also didn't 
work, so it's either a problem with the mailman system itself, or with the 
way it interacts with the particular version of python behaves under RH6.1.

Any help in getting this sorted would be much appreciated, and if you need 
any further information, don't hesitate to let me know.

Yours,

Kev Green, aka. Kyrian.
Comment 1 John Dennis 2003-03-13 16:10:45 EST
closing because this bug is very old and current release is now 2.1.1

Note You need to log in before you can comment on or make changes to this bug.