Bug 31436 - Can't set static routes to ippp (ISDN) devices
Summary: Can't set static routes to ippp (ISDN) devices
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: internet-config   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-11 11:20 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-13 10:08:28 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-11 11:20:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


I can`t set any static routes to my ippp* devices. If i restart the 
network-script (/etc/rc.d/init.d/network restart) after booting the 
routing works. The network script tries to set the routes to the ippp 
devices before the ISDN-Subsystem is loaded... 

Reproducible: Always
Steps to Reproduce:
1.install wolverine
2.setting up a ippp device
3.create a static route to the ippp device

Comment 1 Bill Nottingham 2001-03-12 19:24:44 UTC
ISDN needs to go through the same network initializiation as other devices.
Probably not something that can be fixed for this release, though.

Comment 2 Glen Foster 2001-03-12 19:41:47 UTC
We (Red Hat) should really try to fix this before next release.

Comment 3 Need Real Name 2001-03-13 09:39:00 UTC
What should i do to work around this problem ?

Should i set the static routes in /etc/rc.d/init.d/rc.local ??

It's a really annoying bug, because ISDN is very important in germany.



Comment 4 Ngo Than 2001-03-13 10:08:19 UTC
Before i want to fix this problem, i need your /etc/sysconfig/static-route file

It will help me to fix this problem.


Thanks,

Comment 5 Ngo Than 2001-03-13 14:22:04 UTC
It's fixed with internet-config-0.38. You will find it in the next
rawhide release.


Note You need to log in before you can comment on or make changes to this bug.