Bug 31440 - undefined reference to `__db185_open' on 2.4.2-ac kernel
undefined reference to `__db185_open' on 2.4.2-ac kernel
Status: CLOSED WORKSFORME
Product: Red Hat Linux
Classification: Retired
Component: db1 (Show other bugs)
7.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-11 11:26 EST by mmoneta
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-11 11:26:57 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description mmoneta 2001-03-11 11:26:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-ac9 i686)


When attempting to build 2.4.2-ac18 kernel, receive the following during
make bzImage:

make -C aicasm
make[5]: Entering directory
`/usr/src/linux-2.4.2-ac18/drivers/scsi/aic7xxx/aicasm'
gcc -I/usr/include -ldb aicasm_gram.c aicasm_scan.c aicasm.c
aicasm_symbol.c -o aicasm
gcc -D__KERNEL__ -I/usr/src/linux-2.4.2-ac18/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe 
-march=i686    -c -o misc.o misc.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.2-ac18/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe 
-march=i686    -c -o udftime.o udftime.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.2-ac18/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe 
-march=i686    -c -o tcp_input.o tcp_input.c
gcc -D__ASSEMBLY__ -D__KERNEL__ -I/usr/src/linux-2.4.2-ac18/include
-traditional -c entry.S -o entry.o
gcc -D__KERNEL__ -I/usr/src/linux-2.4.2-ac18/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe 
-march=i686    -c -o traps.o traps.c
gcc -D__KERNEL__ -I/usr/src/linux-2.4.2-ac18/include -Wall
-Wstrict-prototypes -O2 -fomit-frame-pointer -fno-strict-aliasing -pipe 
-march=i686    -c -o unicode.o unicode.c
/tmp/ccrsUMVa.o: In function `symtable_open':
/tmp/ccrsUMVa.o(.text+0x1b5): undefined reference to `__db185_open'
collect2: ld returned 1 exit status
make[5]: *** [aicasm] Error 1
make[5]: Leaving directory
`/usr/src/linux-2.4.2-ac18/drivers/scsi/aic7xxx/aicasm'
make[4]: *** [aicasm/aicasm] Error 2
make[4]: Leaving directory `/usr/src/linux-2.4.2-ac18/drivers/scsi/aic7xxx'
make[3]: *** [first_rule] Error 2
make[3]: Leaving directory `/usr/src/linux-2.4.2-ac18/drivers/scsi/aic7xxx'
make[2]: *** [_subdir_aic7xxx] Error 2
make[2]: Leaving directory `/usr/src/linux-2.4.2-ac18/drivers/scsi'
make[1]: *** [_subdir_scsi] Error 2
make[1]: Leaving directory `/usr/src/linux-2.4.2-ac18/drivers'
make: *** [_dir_drivers] Error 2


Reproducible: Always
Steps to Reproduce:
1.Download/install requisite packages for 2.4.2 kernel
2.Download 2.4.2 
3.Download/apply 2.4.2-ac18 patch
4.Build kernel with aic7xxx SCSI support

Actual Results:  See description

Expected Results:  bzImage generated

Recent changes in the aix7xxx driver build process (see fa.linux.kernel)
have caused breakage due to incompatible db installation in RH 7.0
Comment 1 Alan Cox 2001-05-19 16:35:42 EDT
Since -ac is built on Red Hat I doubt that is the case. You want be sure you
have db3-devel installed and db-devel.

Newer -ac (and Linus 2.4.5pre1 and higher) dont force you to rebuild the
firmware which nicely solves this stuff

Note You need to log in before you can comment on or make changes to this bug.