Bug 31461 - The postinstall script is wrong.
Summary: The postinstall script is wrong.
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: caching-nameserver   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Florian La Roche
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-11 22:24 UTC by hjl
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 19:20:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description hjl 2001-03-11 22:24:45 UTC
The postinstall script does

if ! grep -q "^key" /etc/named.conf; then
  KEY=`cat /etc/rndc.conf |grep secret |head -n1`";"
  if [ -n "$KEY" ]; then
cat >>/etc/named.conf <<EOF
key "key" {
        algorithm hmac-md5;
$KEY
};
EOF
  fi
fi

The problem is

# cat /etc/rndc.conf |grep secret |head -n1
        secret
"c3Ryb25nIGVub3VnaCBmb3IgYSBtYW4gYnV0IG1hZGUgZm9yIGEgd29tYW4K";

It puts `;;' in /etc/named.conf. I got

Mar 11 13:51:53 ocean named[3848]: loading configuration from
'/etc/named.conf'
Mar 11 13:51:53 ocean named[3848]: /etc/named.conf:56: parse error near ;
Mar 11 13:51:53 ocean named[3848]: loading configuration: failure
Mar 11 13:51:53 ocean named[3848]: exiting (due to fatal error)

Removing the extra `;' fixed my problem.

Comment 1 Pekka Savola 2001-03-12 15:13:34 UTC
In 7.1-2 too.  This should _definitely_ be fixed.


Comment 2 Glen Foster 2001-03-12 19:20:35 UTC
This defect considered MUST-FIX (show-stopper) for Florence GOLD

Comment 3 Preston Brown 2001-03-13 23:10:27 UTC
fixed in caching-nameserver-7.1-3 and later.


Note You need to log in before you can comment on or make changes to this bug.