This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 314831 - phpeclipse's httpd conf refers php4
phpeclipse's httpd conf refers php4
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: eclipse-phpeclipse (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Brandon Holbrook
Fedora Extras Quality Assurance
:
: 343811 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-01 19:50 EDT by Doncho N. Gunchev
Modified: 2008-01-15 17:56 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.1.8-17.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 17:56:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Doncho N. Gunchev 2007-10-01 19:50:04 EDT
Description of problem:
/usr/share/eclipse/plugins/net.sourceforge.phpeclipse.externaltools_1.1.8/confs/httpd.conf
refers to php4

Version-Release number of selected component (if applicable):
eclipse-phpeclipse-1.1.8-16.fc7 on rawhide

How reproducible:
always

Steps to Reproduce:
1. install rawhide
2. install eclipse-phpeclipse
3. try running apache (the button on the toolbar)
  
Actual results:
error that php4's apache module can not be found.

Expected results:
php5 should be used

Additional info:
here's quick diff:
--- httpd.conf.dist     2007-10-02 02:43:00.000000000 +0300
+++ httpd.conf  2007-10-02 02:43:16.000000000 +0300
@@ -12,5 +12,5 @@
 TypesConfig /etc/mime.types

 # PHP settings
-LoadModule php4_module modules/libphp4.so
+LoadModule php5_module modules/libphp5.so
 AddType application/x-httpd-php .php
Comment 1 Brandon Holbrook 2007-10-20 23:15:16 EDT
*** Bug 343811 has been marked as a duplicate of this bug. ***
Comment 2 Fedora Update System 2007-10-24 03:03:35 EDT
eclipse-phpeclipse-1.1.8-17.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update eclipse-phpeclipse'
Comment 3 Fedora Update System 2008-01-15 17:56:16 EST
eclipse-phpeclipse-1.1.8-17.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.