Bug 31496 - Install fails on a system with 9 ide drives
Install fails on a system with 9 ide drives
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
high Severity high
: ---
: ---
Assigned To: Michael Fulbright
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-12 08:49 EST by Need Real Name
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-12 12:29:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-12 08:49:53 EST
Default install on an system without any OS.
Install fails on a system with 9 ide drives (absolutely reproduceable):

After chossing Install Type (independent of the chosen one) and proceeding by "Next"
a message shows up:
An error has occurred with trying to create
device nodes for the hard drives in your system.
This may be because you have run out of disk
space on /tmp partion

This may be some kind  of misleading:
At this momemt 1009 out of 4030 1k-blocks are used on the RAM disk where /tmp is located.

System reboots after confirming the message.

System description
Tyan S1867, 2xPIII 733MHz, 256 MB RAM
two 9GB SCSI disks (one on each Symbios896 onboard channel)
one HP Ultrium LTO tape (on second Symbios896 onboard channel)

Maxtor IDE 2.5GB drive on first onboard ide channel
IDE-CDROM on second onboard ide channel

4 promise ultra 66 controllers
8 Maxtor IDE 60GB drive (one on each promise ultra 66 controller channel)

All IDE devices are MASTER

2 GBNIC Netgear GA 620
1 NIC Intel 100pro (onboard)
1 vga Matrox G400

All drives and controllers are recognized correctly when booting from Wolverine install CD
(disc 1)
Comment 1 Michael Fulbright 2001-03-12 11:05:20 EST
Have you had this working with Linux before. It would seem that since the first
Promise Card uses /dev/hde, that you would go beyond /dev/hdh, which I think is
as far as we go with IDE devices.

Michael do you know if this is a kernel limit?
Comment 2 Michael Fulbright 2001-03-12 12:29:36 EST
We were only creating up to /dev/hdh. Fixed internally to go to /dev/hdt.
Comment 3 Need Real Name 2001-03-13 09:14:04 EST
>> We were only creating up to /dev/hdh. Fixed internally to go to /dev/hdt.
Is the current limitation due to anaconda or is this an general limitation of wolverine userspace?
If this is an anaconda only limitation, I'd install with only 4 ide drives and install the big md drive later
manually after reactivating all 9 ide drives.

Note You need to log in before you can comment on or make changes to this bug.