Bug 315161 - Internal error in winbindd causes segfault
Internal error in winbindd causes segfault
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: samba (Show other bugs)
5.0
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Samba Maint Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-02 05:20 EDT by Markku Kolkka
Modified: 2008-01-15 18:47 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 18:47:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Markku Kolkka 2007-10-02 05:20:20 EDT
Description of problem:
winbindd crashes and dumps core at apparently random times, reporting an
INTERNAL ERROR message in the logs. The location in code seems to be the same.

Version-Release number of selected component (if applicable):
samba-3.0.23c-2.el5.2.0.2

How reproducible:
unknown

Steps to Reproduce:
1. enable winbind service
2. wait for a crash
  
Actual results:
Sooner or later winbindd crashes with the following in log:
[2007/09/18 11:48:26, 1] nsswitch/winbindd_passdb.c:add_expanded_sid(131)
[2007/09/18 11:48:26, 0] lib/fault.c:fault_report(41)
  ===============================================================
[2007/09/18 11:48:26, 0] lib/fault.c:fault_report(42)
  INTERNAL ERROR: Signal 11 in pid 2399 (3.0.23c-2.el5.2.0.2)
  Please read the Trouble-Shooting section of the Samba3-HOWTO
[2007/09/18 11:48:26, 0] lib/fault.c:fault_report(44)

  From: http://www.samba.org/samba/docs/Samba3-HOWTO.pdf
[2007/09/18 11:48:26, 0] lib/fault.c:fault_report(45)
  ===============================================================
[2007/09/18 11:48:26, 0] lib/util.c:smb_panic(1614)
  PANIC (pid 2399): internal error
[2007/09/18 11:48:26, 0] lib/util.c:log_stack_trace(1721)
  BACKTRACE: 16 stack frames:
   #0 winbindd(log_stack_trace+0x2d) [0xb3c90d]
   #1 winbindd(smb_panic+0x5d) [0xb3ca3d]
   #2 winbindd [0xb2813a]
   #3 [0x301420]
   #4 /lib/libc.so.6(strlen+0xb) [0x36e30b]
   #5 /lib/libc.so.6(_IO_vfprintf+0x3b22) [0x340f82]
   #6 /lib/libc.so.6(__vsnprintf_chk+0xd1) [0x3e2c21]
   #7 winbindd(dbgtext+0x5c) [0xb26ddc]
   #8 winbindd(fill_passdb_alias_grmem+0x72f) [0xad959f]
   #9 winbindd [0xab6b76]
   #10 winbindd(winbindd_getgrgid+0x3c6) [0xab7766]
   #11 winbindd [0xab1017]
   #12 winbindd [0xab26e8]
   #13 winbindd(main+0x8e9) [0xab1b69]
   #14 /lib/libc.so.6(__libc_start_main+0xdc) [0x317dec]
   #15 winbindd [0xab01f1]
[2007/09/18 11:48:26, 0] lib/fault.c:dump_core(173)
  dumping core in /var/log/samba/cores/winbindd

Expected results:
Winbindd keeps running in a stable fashion

Additional info:
gdb trace:
(gdb) where
#0  0x00fc6402 in __kernel_vsyscall ()
#1  0x003f6c00 in raise () from /lib/libc.so.6
#2  0x003f8451 in abort () from /lib/libc.so.6
#3  0x006fcc0a in dump_core () from /usr/sbin/winbindd
#4  0x00711af8 in smb_panic () from /usr/sbin/winbindd
#5  0x006fd13a in dump_core_setup () from /usr/sbin/winbindd
#6  <signal handler called>
#7  0x0043a333 in strlen () from /lib/libc.so.6
#8  0x0040cf82 in vfprintf () from /lib/libc.so.6
#9  0x004aec21 in __vsnprintf_chk () from /lib/libc.so.6
#10 0x006fbddc in dbgtext () from /usr/sbin/winbindd
#11 0x006ae59f in fill_passdb_alias_grmem () from /usr/sbin/winbindd
#12 0x0068bb76 in winbindd_setgrent () from /usr/sbin/winbindd
#13 0x0068c766 in winbindd_getgrgid () from /usr/sbin/winbindd
#14 0x00686017 in request_finished_cont () from /usr/sbin/winbindd
#15 0x006876e8 in main () from /usr/sbin/winbindd
Comment 1 Simo Sorce 2008-01-15 18:47:26 EST
Unfortunately I can't reproduce this bug so I'll mark this as closed.
Please reopen if you find a way to reproduce it with latest RHEL 5.1 packages.

Note You need to log in before you can comment on or make changes to this bug.